Sign in with
Sign up | Sign in
Your question

Problems with EVGA GTX 670

Last response: in Graphics & Displays
Share
June 10, 2012 11:20:23 AM

Hello everyone,

I'm hoping you can help me with an issue regarding my EVGA gtx 670. I purchased the card at launch and have been playing Diablo 3 and Tera since with no issues at all until a few days ago. I came home from work, started up Tera and after about 15 minutes I got a black screen and some popping in my speakers.

So I try Diablo to see if it is just a Tera related issue. Immediately after logging in a bunch of small black squares cover my monitor. The game works fine other than the fact that half of the screen is covered by this black checkerboard. Tera does not work at all though now. The beginning animations work fine, no artifacting or anything, but as soon as I get to my character screen I get the same black screen as before.

I installed speedfan right after I built my computer and the gpu temp would never exceed 75 degrees under load.

I thought it might be a driver issue causing this so I installed driver sweeper and ran it in safe mode then tried my disk drivers, but no luck. I even tried the new beta drivers.

I read that onboard audio might be messing things up so I disabled it in my bios, but still no luck.

So I thought I would try 3d mark 11 before I did a clean re-install of Windows and it kept shutting down.


My specs:

PSU: Cooler Master 650W 80 plus
Mobo: MSI P67A-GD65 (B3)
GPU: EVGA GTX 670 2GB
CPU: Intel Core i5 2500k @ 3.3
Ram: Corsair Vengeance DDR3 1600
SSD: OCZ Vertex 3 60 gigs (for OS)
SSD: Crucial m4 128 gigs (for games)
OS: Windows 7 64 bit Home Premium


It's so weird; everything was running perfectly up until that point. I hadn't changed anything on my computer for a week prior to the crash.

Haven't done any overclocking yet, as my games had been running perfectly. I used a laptop before this so I don't have a spare graphics card to test, but I suspect my gpu may be the culprit. A bummer since my vacation ends after this week.

Since I'm fairly new with computers I thought I would see what you guys think before I rma my card. I really appreciate any help you're willing to give. :D 

More about : problems evga gtx 670

June 10, 2012 12:07:48 PM

Thank you for the quick response, Recon. No, unfortunantly I don't. I do have a multimeter I could use, however. I'll check it when I get home.
m
0
l
June 10, 2012 12:45:32 PM

is it the factory overclocked version?

been a partial recall on some evga gtx670 sc

m
0
l
!