Sign in with
Sign up | Sign in
Your question

New PC build, not getting any monitor signal

Last response: in Systems
Share
August 1, 2012 9:34:30 PM

Hi, I built a new pc:

The specs are

32GB Ram
i7 3770k lga 1155
Asus b75 motherboard
1.5 TB HDD w/ 60 gb ssd
HAF 912 case
Dvd/blue ray burner
750W 80+ bronze certified PSU corsair

I put everything together and I am not getting a monitor signal

Please keep in mind: My GPU accepts DVI, HDMI and 2 hdmi mini ports.
My motherboard has a DVI and VGA port.
My monitor accepts VGA and DVI no hdmi :/ 
I had no DVI cables so I was forced to use VGA. So i'm using VGA from my motherboard and NOT my GPU.
I still get no signal.

All of the fans turn on, CD drive opens, HDD leds, power switch works, and I even get a post bleep.

What am I doing wrong, could it be that my CPU does not want to be configured with my GPU..

Or maybe I just need to get a DVI cable and plug it into my GPU?

Thanks for reading. I hope I can get this resolved asap.

More about : build monitor signal

a b C Monitor
August 1, 2012 9:39:25 PM

Perform all the steps in our standard troubleshooting guide and let us know how it goes. There's a link to the troubleshooting checklist in my signature.
August 1, 2012 11:13:33 PM

Bought a DVI and it solved my problem.

Thanks.
a b C Monitor
August 2, 2012 2:55:18 AM

i see a problem with your build: you wasted the overclocking ability of the 3770k since b75 doesnt support it

if you werent overclocking it, get a 3770

if you are, get a z77 motherboard instead
!