Sign in with
Sign up | Sign in
Your question

My case's USB 3.0 ports don't work... where is my problem?

Last response: in Components
Share
December 16, 2012 1:46:19 AM

I have recently bought a new case with all the things I upgraded, but I just noticed that my USB 3.0 ports do not work. I have the USE 3.0 cord installed propperly(I think). Is there something you have to do on windows or the BIOS to initialize ports that have simply been switched out for others that are the same?
December 16, 2012 2:04:19 AM

How so don't they work? Like they don't operate at USB 3.0 speeds? Or they just don't work with any USB device at all?
m
0
l
December 16, 2012 3:06:48 AM

They don't work with any USB device, but the 2.0 ones on the case work. I have the USB 3.0 plug plugged into the propper place on the Mother board.
m
0
l
Related resources
December 16, 2012 6:45:29 AM

Some motherboards provide USB3 ports via a secondary chip and need the driver installed, also check that it is enabled in bios.
m
0
l
December 16, 2012 4:36:53 PM

How would on go about checking to see if it is enable n the BIOS? The interal port is directly connected to the motherboad not a secondy chip.
m
0
l
December 16, 2012 5:37:03 PM

Press 'delete' or 'F2' when you turn the Pc on, that should get you into the bios screen, and there may be a usb3.0 related box in one of the tabs
ensure that it is set to enabled
Moto
m
0
l
December 16, 2012 10:33:05 PM

when it turns on mine says press esc for startup menu and I don't see USB 3.0 anywhere in the menus, but my old case had two USB 3.0's so I don't understand why there is no setting for it. It appears that there is no power going to the ports but the USB 3.0 connecteris plugged in. Is there any other connection that I need?
m
0
l
December 16, 2012 11:18:33 PM

In Device manager if I add the device will it work? I unplugged the 3.0 plug and replugged it into the motherboard and nothing happened.
m
0
l
!