Sign in with
Sign up | Sign in
Your question

ATI 7970 going into power save mode mid game?

Last response: in Graphics & Displays
Share
June 12, 2012 8:41:42 PM

Just got a 7970 as an upgrade from a GTX460, most games run fine - brilliantly to be honhest - Crysis, BF3, Dirt etc. All the demanding games run fine, thing is, when I try to play an older title such as Call of Duty 4 of a less demanding game League of Legends for example, the cards core speeds seem to drop from 925 down to 501 or even 300. I know that this would be normal if I was browsing the web etc but in-game it is just plain frustrating.

Is there some way of disabling the power saving features? I kinda want the performance I have paid for, not the performance the Greenpeace would like me to have!

Any help would be great!

Thanks,

Click
a c 87 U Graphics card
June 12, 2012 8:57:19 PM

so are you getting poor performance because of this?
if the game is light enough and fps is capped with vsync, the load on the gpu willl be so low that it doesnt have to use all of its power to hit the fps cap...

on the other hand, if you are getting like 10fps it would be annoying :D 
June 12, 2012 9:00:17 PM

COD4 Max settings, no v-sync, FPS capped at 250 (promod). Random drops in fps to around 20fps for a couple of seconds then it comes back up.
Related resources
a c 87 U Graphics card
June 12, 2012 9:06:47 PM

well that is nasty...
you could tweak the bios with radeon bios editor, but that is a bit extreme...
a b U Graphics card
June 12, 2012 9:27:19 PM

This isnt a problem with any 7970 ive owned and ive had 5 in my possesion at 1 time or another since theyve been released. This is a unique issue with him.
a b U Graphics card
June 12, 2012 9:30:10 PM

RBE doesn't support the 7000 series last I checked. Are you running Overdrive?
a b U Graphics card
June 12, 2012 9:39:05 PM

Have you tried to force it to stay on maybe by overclocking it? With no to minimal voltage adjustment you can hit 1125/1575 with these cards pretty easily.
June 15, 2012 9:12:23 PM

i have overclocked it to 1000 to see if o/cing it would help, and no. my 5970 used to do it with COD4 too, but there was a way of forcing it to stay in higher clocks with CCC back then... ah well i will just have to play demanding games!!!
June 15, 2012 10:18:26 PM

Just cracked it. Saw that there is a lot of talk on G3d about enabling unofficial O/C mode in afterburner through the config. Did that, I know have the performance I payed for and can play without stupid lag!

Thanks guys!
a c 87 U Graphics card
June 16, 2012 9:51:13 AM

Thank you for sharing the solution. :) 
!