Sign in with
Sign up | Sign in
Your question
Solved

670 on games Question

Last response: in Graphics & Displays
Share
June 12, 2012 10:43:04 PM

I purchased a 670 about a week ago, and it is freaking amazing. It blows my old 6970 out of the water. It's currently overclocked for a 7088mhz data rate. However, when I play Crysis or Crysis 2 (with Tesselation and High-Rez textures) I never get above 25 frames. Both are completely maxed minus the AA. I open Precision X and my power consumption is only at 30%.
My question is how can I get above 25frames? I'm not trying to be picky, but it's just annoying. Thanks.

More about : 670 games question

a c 388 Î Nvidia
June 12, 2012 10:44:28 PM

Maybe you have a slower CPU?
m
0
l
June 12, 2012 10:46:27 PM

I have a Phenom II X4 925(I believe) O.C.'d to 3.5ghz.
m
0
l
Related resources
a c 388 Î Nvidia
June 12, 2012 10:48:33 PM

If, when you write that your power consumption is 30%, you actually mean your GPU usage is 30%, then that is an indication that your CPU is bottlenecking your very fast GPU.
m
0
l
June 12, 2012 10:51:10 PM

It's not even that old of a Cpu. I'm not trying to sound like a douche or anything. But could it really be that?

Edit: I downloaded TMonitor. And it only pushed one core. The others are just sitting there while playing
m
0
l
June 12, 2012 11:24:30 PM

Roll back to older drivers.
m
0
l
a c 80 Î Nvidia
June 12, 2012 11:28:45 PM

Also, if you overclock your DDR5 memory too high, it will slow down your speeds. DDR5 has error correction, so it'll allow you to go to the point of having errors, but you won't know it, because it will spend time correcting those errors, and slow you down.

It is also possible you are overclocking so high, it draws more power than the card is allowed with the new power management feature, which can result in throttling. There is a way to increase that within MSI afterburner, and probably Precision as well.

And it could also be your PSU is just not strong enough and throttles you.
m
0
l
June 12, 2012 11:54:34 PM

Well, I fixed it. I restarted the PC and it works fine now. Everything jumps up as soon as I start the game. I don't honestly know why it wasn't working. Thanks for the help guys. I guess I should have restarted it first. I don't know what did it.
m
0
l

Best solution

a c 388 Î Nvidia
June 13, 2012 12:12:12 AM

breakformula said:
Well, I fixed it. I restarted the PC and it works fine now. Everything jumps up as soon as I start the game. I don't honestly know why it wasn't working. Thanks for the help guys. I guess I should have restarted it first. I don't know what did it.

I think that's a bug with the recent drivers that causes the clock speeds to set well below normal 3D clocks. Restarting the PC has always fixed it for me. I read that they are fixing it in a newer driver release. Setting the Power Management Mode to "Prefer Maximum Performance" may help.
Share
June 13, 2012 1:25:23 AM

Best answer selected by breakformula.
m
0
l
!