Sign in with
Sign up | Sign in
Your question
Closed

A diiferent kind of battery fault

Last response: in Components
Share
December 18, 2012 5:42:43 AM

I may have a problem with my laptop battery but it is not the typical problem of a worn out battery.

My battery holds charge very well, charges to 100% as when new (I year ago) and lasts the full time it is supposed to when the machine is running on battery only.

It's an Acer Aspire 1 Netbook Model D257.

The problem is that when the battery is in (both when the machine is running on battery only AND when the PSU is connected) the netbook can take up to 5 minutes to get started. I mean that it takes a long time before it even STARTS booting, before anything appears on the screen.
I can leave it but sometimes I may have to switch it on and off up to ten times to get it started.

But once it is booted it is rock solid unless I disconnect the PSU when the battery is in, then the machine sometimes switches off immediately as if the battery wasn't giving any power.


There is no delay in starting if I use the laptop on PSU without the battery in

Clearly the battery can hold a charge and can deliver it over a prolonged period but it may have a problem when first called on to deliver that charge, as if it takes time to "get going".


Can batteries have such a fault?
Can it be fixed?
December 18, 2012 7:12:10 AM

I reccomend buying a new battery and power adapter.

Has it still got warranty?
Score
0
December 18, 2012 8:25:47 AM

I considered a new battery but I did also want to understand the problem.

The battery is otherwise fine so I am not going to replace it and the PSU is an expensive multi-system one just a few months old

However I did clean the contacts on the battery and computer and now it is working. Fingers crossed.

I'll post this as the solution if the problem doesn't recur in the next week or so.

Thanks
Score
0
Related resources
December 18, 2012 8:33:53 AM

As long as it's working all is well.
Score
0
December 21, 2012 4:19:19 AM

actually it reverted back to broken ....
but another cure was presented, that worked.

I replaced the CMOS battery!

(in my machine the battery is on the top of the motherboard, you have to remove the top cover of the chassis. First you lift up the keyboard (no screws, just clips to push past), then you unscrew the top cover from the motherboard (some of the screws are holding the bottom cover so leave these)
The battery is on the front left hand side, to the left of the keypad. It's a fully removable silver flat disk watch-type battery, no cables)

How can I mark this as SOLVED?
Score
0

Best solution

December 21, 2012 8:07:23 AM

Select best answer
Share
December 21, 2012 10:01:37 AM

Best answer selected by diapolical.
Score
0
!