Sign in with
Sign up | Sign in
Your question
Closed

Can't get standoffs in : /

Last response: in Components
Share
December 19, 2012 7:10:03 PM

So I'm trying to install standoffs in my nzxt phantom 410. Only problem is, they get stuck half way, in about 6 of the 9 holes it gives for atx boards. I think I am putting in the standoffs perfectly straight. I just don't understand why I can't get them to go in. This sounds like a noob question but does anyone have any advice?

More about : standoffs

a b ) Power supply
December 19, 2012 7:15:23 PM

could be the stand offs or the holes have been badly machined

could try tightening them with pliers
Score
0
December 19, 2012 7:18:54 PM

mcnumpty23 said:
could be the stand offs or the holes have been badly machined

could try tightening them with pliers


Couldn't I strip it? : /
Score
0
Related resources

Best solution

a b ) Power supply
December 19, 2012 7:39:29 PM

possibly

if you have a spare stand off test in one of the holes you arent going to use

i have had this before and tightened them with pliers no problem

more likely to strip it if you keep removing the stand offs and putting them back in

doing it once usually just makes them bite if they are badly machined
Share
December 19, 2012 8:16:15 PM

mcnumpty23 said:
possibly

if you have a spare stand off test in one of the holes you arent going to use

i have had this before and tightened them with pliers no problem

more likely to strip it if you keep removing the stand offs and putting them back in

doing it once usually just makes them bite if they are badly machined


Allright thanks. I'm pretty sure I've got them in good now :) 
Score
0
December 19, 2012 8:16:26 PM

Best answer selected by TheScarecrow97.
Score
0
!