Sign in with
Sign up | Sign in
Your question

[Solved] USB 3.0 port not working

Last response: in Components
Share
December 20, 2012 2:07:29 AM

Hello everyone! I've never posted here before, but I'm not sure where else to look for help. Google wasn't much help, so I'm looking to all of you tech savvy people.

Here's my problem... I recently bought a USB 3.0 compatible external harddrive because a computer I bought earlier this year has two USB 3.0 ports on the front of the tower right beside one another. One of the ports works great and has the fast read/write speeds you'd expect from USB 3.0. However, the other USB 3.0 port doesn't work as it's supposed to. When I plug my external drive into it I get that horrible Windows "This device can perform faster..." notification. Its read/write speeds are also just about in line with USB 2.0 speeds. I find it more perplexing that only one of the ports appears to not be working correctly.

I'm not sure what specs you'll need, but I'll add a few here and if you need more I can provide them as best I can.

OS: Windows 7 Home Premium 64 bit, SP 1
Processor: Intel Core i5-3570K
Motherboard: Asus P8Z77-V-LX

Under my Device Manager I only see one Intel USB 3.0 eXtensible Host Controller, and one Intel USB 3.0 Root Hub. Would I see two if both ports were working correctly?

I don't know if you need this information, but I figure I'll add it anyway:

Intel 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26
Intel 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E2D

I also just updated my Intel USB 3.0 eXtensible driver (10/16/2012 update). Windows tells me my drivers are up to date, but I'm always skeptical. Are there other drivers I should know about and update?

Thank you in advance to anyone who can help me out!
December 20, 2012 2:41:19 PM

Welcome to Tom's Hardware Forums,
Your motherboard only features one USB 3.0 header - it controls both front panel USB 3.0 ports so I'm going to point my finger at the front panel or the USB 3.0 cable going to the front panel. It seems to me that you have a few options; 1) make mental note that you can't use that port for USB 3.0 connections and simply continue to use as is. 2) Attempt to locate the problem area on the front panel or wires yourself and repair it (or have it repaired). 3) RMA computer case. I think RMAing is a little drastic but if you need two USB 3.0 ports in front...
Hope it helps
m
0
l
December 20, 2012 9:41:01 PM

Thank you for the welcome!

Hmm, all right. I was hoping it wasn't a hardware problem, but I knew it was definitely a possibility. I do have a USB 3.0 hub with four extra ports so I could use. I was hoping to have five, but I can be happy with four until I fix the problem.

Thank you for your help!
m
0
l
!