Problems uninstalling/install new catalyst drivers

Hello everyone,

Ok so I ran into some problem with my graphic drivers lately whenever I try to install drivers it does'nt install them (it says some error occured but when I click the report it says all the installed worked correctly)

I tryed numerous things to properly erase all trace of the old catalyst drivers but nothing worked, driver sweeper(safe mode even) uninstall from peripherals, delete registry entries, nothing.

In my catalyst control center it still display my old drivers 11.12 ... when I should be having 12.4.


By the way I got a hd5870, and using vista64.

So my question is there any sneaky tactic to really delete all traces of all ati/amd drivers previously installed ?

Oh I also tryed to use some tool called atiman that was recommended on some forum a few months ago, that did'nt helped either.
7 answers Last reply
More about problems uninstalling install catalyst drivers
  1. What driver shows in the device manager?
  2. 8.980.0.0


    Oh.. thats the 12.6 beta forgot I also trying to install these yesterday, but I believe it was already wrong before that.

    So my drivers are up to date and my catalyst control center showing me wrong ? weird :(

    here by the way I took a screen of the CCC http://img703.imageshack.us/img703/127/atiprob1.png

    Thanks for your help.
  3. Yes your drivers are up to date....ccc is showing it wrong.
  4. Ah yea thank you ! I did'nt thought bout checking there :) .
  5. Glad to help!
  6. 12.4 is bugged, the drivers will show as whatever version you had before, but its really 12.4
  7. Same here!
Ask a new question

Read More

Radeon Drivers Catalyst Graphics