Sign in with
Sign up | Sign in
Your question
Closed

NVIDIA installer failed

Last response: in Graphics & Displays
Share
June 16, 2012 6:33:48 AM

Hello everyone,

I wanted to update my drivers because I was trying to play a game and it mentioned that my drivers weren't up-to-date. So I went to the official nvidia website and downloaded the latest drivers: 301.42-desktop-win7-winvista-64bit-english-whql and tried to install them. Whenever I try this it get's stuck at the graphics drivers and says NVIDIA installer failed.

Screenshot: http://i46.tinypic.com/rlgg83.png

Things that I've tried:

* Nvidia's clean installation option
* Used Driver Sweeper to remove previous Nvidia related files
* Tried to install it in safemode
* Disabled BitDefender (msconfig)
* Removed BitDefender

System specs:

Windows 7 64 Bit
Nividia Geforce GTX 570

I hope that someone has an idea.

Greetings,

Qwertyrules
June 18, 2012 4:32:09 AM

Did you uninstall previous drivers - or just remove them? - i have tried to install new drivers on top of old - it did not work - but then i uninstalled old drivers - and restarted and installed new - that worked..
June 20, 2012 7:45:51 AM

Try renaming the folder "C:\Program Files\NVIDIA Corporation" , i tried many ways, deleting registry entries, system restore, traditional uninstall, compatibility mode, etc. but nothing worked, only when i got renamed that folder VOILA! it worked. (That worked for me).
Related resources
Can't find your answer ? Ask !
June 23, 2012 5:47:51 AM

It has compatibility issues, i have faced that problem. I have installed upgrade from "win 7 64 bit" to "win 7 64 bit service pack 1" then the latest nvidia driver worked fine.

here is a link,
http://download.microsoft.com/down [...] 32-X64.exe

follow these steps;

1-Install win 7 service pack 1 upgrade
2-Go to safe mode & uninstall nvidia driver.
3-Back to the windows and install latest nvidia driver.
August 12, 2012 4:26:30 PM

You will NOT believe the solution I found for this. It blew my mind.

Instead of using the pack executable, find C:\NVIDIA\DisplayDriver\304.79\WinXP\English (or whatever is appropriate for the driver you tried to install) and simply run the setup.exe you find there.

I know the pack is likely using that program anyway, but for some reason running from it there installed everything without a hitch.
!