Sign in with
Sign up | Sign in
Your question

Razer USB Mouse and Keyboard stopped working

December 22, 2012 1:04:41 AM

Hi guys!

I bought this PC a few months ago and I'm having this really annoying problem with either the USB ports of the mobo or the Keyboard and Mouse. The problem is I can't figure out what exactly is going on.

The mobo is a GA-H61M-DS2 from Gigabyte and I'm using a set of Razer keyboard and mouse (Cyclosa and Abyssus, respectively)

Yesterday I was playing some games and the mouse stopped working. I tried to change the usb ports and realized that it would only work if both the mouse and keyboard were in the lower set of ports (there are 4 ports on the rear IO, two sets of two USB 2.0 ports). So it was working again, but I was already annoyed because I couldn't figure out why the top ports woudn't work. I tryed using other peripherals on the top ports and everything worked fine.

Today both the mouse and keyboard stopped working. I changed the ports again and after some time it started working. But 5 minutes later it stopped again. And this time it didn't matter which ports I used.

So I grabed my sister's apple keyboard and mouse to see if they worked, and they did! And the weirdest part is that if I'm using the Abyssus mouse in the USB port on the Apple Keyboard it works fine!!

What I can't understand is why this is happening, since everything worked fine for more than a month.

I may be relevant to say that I had some similar problems with the rear USB ports in the first week when I got the PC. They randomly stopped working and would work again after some swapping. But this doesn't seem to be the same, since everything works, except the razer mouse and keyboard.

Anyone has any clue about this (questionmark... yeah, I can't figure out where is the question mark in this stupid apple keyboard)
!