Sign in with
Sign up | Sign in
Your question

DNS Client Event; Event ID 1014

Last response: in Networking
Share
August 10, 2011 12:06:22 PM

Hello,
For about the past year everyone in my family have been experiencing connection time outs. We have 3 computers that are connected via cable to our router modem, while a laptop is wirelessly connected to our router. We use a Belkin 54G router.
I've slightly reduced the number of timeouts for our computers by disabling TCP/IPv6 and power management tools, and switching our speed and duplex to 10Mbps half duplex. Just recently I used command prompt to disable these features as I heard they can cause this issue:

netsh interface tcp set global rss=disabled
netsh interface tcp set global autotuninglevel=disabled
netsh int ip set global taskoffload=disabled

I did this after reading

Recently I've discovered Event Viewer, and through this I found that DNS client events, event ID 1014, happens when my connection drops. Also, sometimes the ID is 1006, and other times the event is Time Service or DistributedCOM. This is best shown in an image:


I find that 1014 is the most common event. I am using Windows 7, all my drivers are up to date.
August 10, 2011 4:31:18 PM

10Mbps Full Duplex would be better. Running at Half is probably hurting you more than you think.

Call your ISP and have them run a diag against your modem. It may have issues or need updated.

If you know your DNS server's IP address(es) you could try to plug them into each computer to directly communicate with the servers. This all depends on your setup, if you have a router in place, or if your computers are getting the IP address from your ISP provided hardware.
August 10, 2011 8:47:28 PM

I only have 1 cable running to my router - is it ok to have it at 10Mbps Full Duplex?

I think my router can only transmitt 54 mb of data in total - if 3 of us were on and we were all using full duplex would this result in connectivity issues?

My dad likes to do everything with the router - but he hasn't updated it yet. He says manually changing the router's IP address to something slightly different may solve the issue, instead of using the address provided by our ISP, which is Orange I believe.

I am not knowledgable in networking, so if there's any other details you need to know just ask and I will edit the top post.
Related resources
August 11, 2011 2:57:52 PM

100/Full would be fine. You would want to make sure your NICs on the computer are set to 100/full in the Device Manager as well. This is basically hard coding them. The quality of your cable may also have some affect on it along with the length but I doubt you have a couple hundred foot cat5 cable.

Duplex is like a highway. Full duplex is a two lane road, coming and going. Half duplex is a single road where incoming or outgoing can only happen, not both at the same time - like talking on a walkie-talkie. Only one person can talk, the other has to listen.

Your ISP will provide a Public IP to your router. Your router in turn will provide private IPs to the computers it is connected to - most likely a 192.168.x.x number.

I would disable all IPv6 on the computers and the topology mappers, etc. This is only going to create extra traffic and not really required in your case.

How are you testing your connection to verify packet loss, etc? I would still contact the ISP to see if they detect any issues with your connection.

Also, depending on settings in your router that may have changed, that could also cause some issues.

Another thought, look at adjusting the MTU from your computer to the router. If you can adjust it on the router as well, you might want to do that. You can determine what size MTU packet to use by using the Ping command with the -L switch. Google on how to determine your MTU size and it should give you a write up. I'm not able to verify the steps in my current environment.



August 11, 2011 8:33:06 PM

OK, numbers = paragraph number.

1st: I've changed to 100/full, through LAN and device manager. I'm only changing things on my computer at first, to keep things simple.

4th: I've now disabled both of these.

5th: I'm unsure what you mean by packet loss, but I may have inadvertantly tested it anyway - read 7th paragraph

7th: Ok, following instructions from this website http://www.richard-slater.co.uk/archives/2009/10/23/cha..." target="_blank">[/url I adjusted the MTU value to 1492. I found this value by finding the last succesful MTU value before packet loss, and then adding 28.

Thankyou for the help, much appreciated. I've followed these steps through fully, so I shouldn't be losing connection anywhere near the amount I have been. I'll report back in 4-5 days and then tell you my how it's going.
August 11, 2011 9:05:28 PM

Edit (it seems I'm not allowed to edit my posts?): There is no need to wait as I have just dropped twice. My router is up to date, but I think the issue may be with the router. I'll see about changing the MTU on the router, and calling my ISP. But it seems like it's a problem with with the router/or ISP, as all 4 machines are being affected in the same way.
August 17, 2011 8:53:43 PM

SOLUTION: (top result).

I followed Method one, number 1. This disabled RSS, autotuning and Task offload. I have no idea what they are or how disabling it helps. I don't have Event 1014 (or 1006 which follows it) anymore, except when my computer is starting up. I rarely get timeouts now!

Thankyou Riser for your help here.
!