Sign-in / Sign-up
Your question

Graphics Card Working But Not Detected - Cannot Play Any Games, Help?

Tags:
  • Nvidia
  • Graphics Cards
  • Graphics
Last response: in Graphics Cards
June 18, 2012 3:27:49 PM

Hi, first post here.

Just gonna throw my specs out quickly:

CPU: Intel Q6600 quad core 2.4ghz
GPU: nVidia 8400 gs
RAM: 2gb
OS: Windows 7 Ultimate 32bit

I've been using this computer without fault for 3ish years. It's pretty low spec, but can play the games I want at alright quality. Yesterday, I got a BSOD, and I just restarted my computer and it booted up as normal. I tried to play League of Legends, but it came up saying "Cannot load Direct3d". I tried to load Team Fortress 2 and it didn't work either. I also tried Minecraft, but it came up saying "No card with openGL found", which I know for a fact it does as I was playing Minecraft the day before.

I decided to check dxdiag, but according to the "Display" tab, there is no graphics card installed. Everything apart from "Current display mode (Which is showing the correct resolution)" says n/a. This leads me to believe that, while the graphics card is working (How else would I be able to see what I'm typing now? There's no build-in graphics card by the way), it has not detected it as being a proper card and therefore nothing with DirectX or OpenGL is working.

However when I go to the nVidia site and choose to update my drivers, I clicked "Find my graphics card for me" and it selected the right one, so it must recognise it somehow.

I have re-installed and re-updated all the drivers, and taken out the card itself and put it back in properly, to no avail.

Does anyone have any ideas how to fix this?

Thanks.

More about : graphics card working detected play games

October 2, 2012 12:27:07 AM

I have the exact same problem! Q6700 4gb ram 9500gs. Someone please help
December 31, 2012 9:15:21 AM

Same problem here. My computer one day gets into a BSOD circle so I restore to factory defaults just like the other 50 times I have done this, But the when I update my nVidia graphics card it doesn't detect it............................. :fou:  FUUUUUUUUUUUUUUUUUUUUU. And the strange thing is that it seems to work but I need it to update. I have done everything I can do and I am just out of options expect to buy a new pc. Help me please D:

CPU: Intel Core i5 650 3.20GHz
GPU: nVidia geforce 520
RAM: 8gb
OS: Windows 7 Home Premium 64-bit
MODEL: Acer Aspire X5900