Sign in with
Sign up | Sign in
Your question

Sapphire Radeon HD 3650 problems

Last response: in Graphics & Displays
Share
June 19, 2012 2:55:17 PM

Hello,
Up until yesterday, everything was working fine. Turned on the pc this morning, it's old but still runs! And the graphics had reverted to onboard VGA, test coneections on the card, all fine, none had come lose. Checked in the system and there was an exclamation mark. So took out the old cd, installed old drivers and all fine.
But I did update the drivers a while back and seem to have misplaced them somewhere.
So went to the Sapphire site where there are hotfixes??? Anyway, chose my card, system and then 12.4 drivers, but on installing the new drivers, there is an error with the install saying 'Application Install:Install package failure' and when detecting my card, it detects a Visiontek HD 2600XT and installs the driver for that.
So I then have to uninstall the drivers and install the old ones from the disk which work fine.
Also noticed the catalyst software on the new install doesn't work either.
I've tried some of the older updates and it always seems to detect the wrong card with a package failure error.
Any ideas how I can update the drivers?
Cheers
June 19, 2012 3:09:36 PM

Seems like the 3650 is dead and the bios has activated the onboard because of that. Maybe it's time for an upgrade? There are a lot of cheap cards that have at least triple the performance of a 3650.
June 19, 2012 7:39:56 PM

No it's working with old drivers!
June 20, 2012 3:23:33 AM

Interesting. Well I guess the 12.4 have struck again. Just leave it with the old ones if it's OK with you.
!