Sign in with
Sign up | Sign in
Your question
Closed

HD 7950 High Performance Mode

Last response: in Graphics & Displays
Share
June 19, 2012 8:22:31 PM

UPDATE: Running flash video whilst playing games caused high-performance mode to not activate on my 7950, when I do not have flash video running it activates just fine and I can get the frames per second in games that I should be getting. There is two possible fixes for the flash video, 1) you can stop watching flash video entirely whist playing games or 2) you can right click flash video and click disable hardware acceleration, either will allow high-performance mode to be activated when you are playing a game. I hope this helps anyone else who was having this problem.

I purchased a MSI 7950 (this one to be exact: http://www.msi.com/product/vga/R7950-2PMD3GD5-OC.html ) shortly after it came out. I am using it to run a dual monitor setup. Recently, I have noticed that while playing games, it does not activate high-performance (3D) mode for gaming. For example, I am playing Diablo 3 right now on my first monitor, and the GPU clock is only 501MHz when I have this cards core overclocked to 930MHz. I have had this problem with both Catalyst 12.4 and the Catalyst 12.6 beta driver. I have ran CCLeaner before and after each install/uninstall and it does not help. Does anyone know why this could be? Is there any way I can force it to run in high-performance mode, or any way to fix this problem? Any help would be greatly appreciated.
June 20, 2012 1:41:26 AM

What are your computer's specifications, especially PSU specs? Also, I'm pretty sure that bumps aren't allowed. You could have asked a question or elaborated on something instead.

Also, have you tried testing your card without the overclock? It might be throttling and the overclocking might be causing it.
Score
0
June 20, 2012 1:51:48 AM

My PSU should probably be fine, considering it handled a 5850 overclocked fine and it requires the same PSU power cables. My entire system is quite good:
Motherboard: Asus P7P55D-E Pro
Case: Antec Six Hundred
Processor: Intel Core i7 860 @ 3.7GHz
RAM: G.SKILL 8gb DDR3 1600MHZ
CPU Cooler: Arctic Cooling Freezer 13 Pro
Graphics Card: ATI RADEON HD 7950 3gb GDDR5
HDD: Western Digital Black Caviar 1TB 7200RPM 32MB Cache
HDD2: Western Digital Black Caviar 2TB 7200RPM 64MB Cache
SSD: Crucial M4 128GB
Monitor 1: Asus PA246Q 24"
Monitor 2: Dell 24" of some sort
Power Supply: Coolermaster Silent Pro M700 - 700w
Mousepad: Steelseries 9HD
Mouse: Razer DeathAdder 3.5G
Keyboard: Razer Blackwidow Standard
Sound Card: Asus Xonar DX
Headphones: Sennheiser PC350
I have tested it without the overclock, it has the same problem, and I have tried using MSI Afterburner and it still has the problem.
Score
0
Related resources
June 20, 2012 1:56:18 AM

I asked for the PSU specifications because from the looks of this, it is a probable cause of your problems and this is an AMD 7950. ATI is only Radeon 5000 and older. Also, needing the same PCIe power connector does not mean that they have similar power consumption. For example, the 7770 has a single 6 pin power connector, yet uses far less power than many other cards that also use a single 6 pin power connector.

Looking at your PSU, it definitely could be the problem. How old is it?
Score
0
June 20, 2012 2:12:34 AM

blazorthon said:
I asked for the PSU specifications because from the looks of this, it is a probable cause of your problems and this is an AMD 7950. ATI is only Radeon 5000 and older. Also, needing the same PCIe power connector does not mean that they have similar power consumption. For example, the 7770 has a single 6 pin power connector, yet uses far less power than many other cards that also use a single 6 pin power connector.

Looking at your PSU, it definitely could be the problem. How old is it?

My PSU is from December 2009 I believe, I think it is from some time in 2009 but I don't remember for sure. I don't see why my PSU would be the problem. When high performance mode does work and it goes to 930MHz core clock speed, it can handle it fine without a single problem for hours, but if I exit out of that game and play another game, it sometimes will not activate high-performance mode.
Score
0
June 20, 2012 2:59:27 AM

How do you know if high performance mode is activated or not? what is high performance mode?
Score
0
June 20, 2012 3:02:29 AM

jijoslin said:
How do you know if high performance mode is activated or not? what is high performance mode?

High-performance mode is when it applies your overclock. If you overclock from 810MHz to 930MHz for example, it will not run the card at 930MHz until it enters high-performance mode, for example when it detects you launch a game or get a lot of activity (I assume). However, in my case, this sometimes works fine and it runs the card at the specified overclock, but other times it stays at 501MHz when I am playing a game and thus does not provide the highest FPS possible.
Score
0
June 20, 2012 3:08:59 AM

i_pk_pjers_i said:
High-performance mode is when it applies your overclock. If you overclock from 810MHz to 930MHz for example, it will not run the card at 930MHz until it enters high-performance mode, for example when it detects you launch a game or get a lot of activity (I assume). However, in my case, this sometimes works fine and it runs the card at the specified overclock, but other times it stays at 501MHz when I am playing a game and thus does not provide the highest FPS possible.

The reason I was asking is that I have two of these cards in two seperate pc's one at 1050 core/1575 memory and the other at 1100/1575 this is with a voltage bump to 1.149, what is a good program to monitor actual in game frequencies?
Score
0
June 20, 2012 3:11:31 AM

i_pk_pjers_i said:
High-performance mode is when it applies your overclock. If you overclock from 810MHz to 930MHz for example, it will not run the card at 930MHz until it enters high-performance mode, for example when it detects you launch a game or get a lot of activity (I assume). However, in my case, this sometimes works fine and it runs the card at the specified overclock, but other times it stays at 501MHz when I am playing a game and thus does not provide the highest FPS possible.

Try occt its an overclock test that you can test psu,gpu etc... but I think it could be your psu
Score
0
June 20, 2012 3:26:55 AM

jijoslin said:
Try occt its an overclock test that you can test psu,gpu etc... but I think it could be your psu

When I run OCCT, it sometimes runs the card at 930MHz, other times it does not. When it runs at 930MHz, it can run stable for over an hour with no errors before I get bored and exit out of it. The problem is NOT the overclock, the problem is high-performance mode does not properly activate sometimes. 930 MHz is completely stable, and I bet even higher would be too, it's just that it doesn't always use that core speed when it really should, which is why I think the issue is not hardware related or anything to do with my PSU etc, I think the problem is software related.
Score
0
June 20, 2012 4:09:35 AM

AMD cards do tend to get stuck in there 2d clock speeds my 5770 use to do it, my 7950 has done it once or twice. does it stick to the slower clock tell you reboot or does it randomly decide to speed up if you re open a program
Score
0
June 20, 2012 4:13:59 AM

zakattak80 said:
AMD cards do tend to get stuck in there 2d clock speeds my 5770 use to do it, my 7950 has done it once or twice. does it stick to the slower clock tell you reboot or does it randomly decide to speed up if you re open a program
Sometimes it activates the high-performance mode, other times it sticks at a core speed of 501MHz.
Score
0
June 20, 2012 5:59:58 AM

i_pk_pjers_i said:
Sometimes it activates the high-performance mode, other times it sticks at a core speed of 501MHz.


hmm, my cards wouldn't even boost up a little bet, mine stayed at 300 mhz when it did that. i'm starting to think that it is likely a power problem like everyone is saying, but you say it never throttles back down if it does boost up.

Are you sure you have the latest drivers?
Score
0
June 20, 2012 6:54:34 AM

zakattak80 said:
hmm, my cards wouldn't even boost up a little bet, mine stayed at 300 mhz when it did that. i'm starting to think that it is likely a power problem like everyone is saying, but you say it never throttles back down if it does boost up.

Are you sure you have the latest drivers?

I highly doubt it is a power problem, my PSU is very good, cooler master makes great PSUs, and this graphics card is not even that power intensive, in fact my old 5850 might have consumed more power than my 7950 although I am not sure. Like I have stated in my first post, I have tried with the beta and stable versions of the driver.
Score
0
June 20, 2012 7:39:25 AM

How many overclocking programs do you have install if any? There could a conflict between the core settings
Score
0
June 20, 2012 8:36:53 AM

zakattak80 said:
How many overclocking programs do you have install if any? There could a conflict between the core settings
I have tried with just AMD CCC, and with AMD CCC and MSI Afterburner. It does not matter how many overclocking programs I have, the problem still persists. At the moment, I am only using AMD CCC and I still have the problem.
Score
0
June 20, 2012 8:43:16 AM

i_pk_pjers_i said:
I highly doubt it is a power problem, my PSU is very good, cooler master makes great PSUs, and this graphics card is not even that power intensive, in fact my old 5850 might have consumed more power than my 7950 although I am not sure. Like I have stated in my first post, I have tried with the beta and stable versions of the driver.


Cooler Master does not make PSUs. They re-brand cheap PSUs and they are not great nor nearly the most reliable. You are also pushing your PSU pretty hard with all of that hardware and it's getting old, so it is most likely at least contributing to your dilemma, if not the sole cause. Also, when you've changed drivers, do you boot into safe mode, completely uninstall all AMD/Ati graphics drivers (and all other related software), re-boot into safe mode, install the new driver version, re-boot normally, and then test it out?
Score
0
June 20, 2012 9:45:05 AM

Quote:
Ya As you say Cooler master does not make PSU.
And you also said it for corsair that they don't make their own PSUs
Oh! Sorry Did i say CM and Corsair only No company make their own psu.
They buy from you and then they rebrand it and sell. :pt1cable: 


I never said that for Corsair. Corsair sells excellent PSUs. Cooler Master is known to not make their own PSUs and that they re-brand less than ideal PSUs. This is why Cooler Master often has more efficient, modular power supplies (among several other companies who do similar work in the PSU market to Cooler Master) at lower prices than the better brands, such as Corsair, Antec, and Seasonic.
Score
0
June 20, 2012 2:05:53 PM

Do you have any other programs running while playing the games. I have the exact same issue (Radeon 7950) BUT I managed to isolate it and figured out, Windows Media Center is causing it for me. If I have Media Center open the video card wont ramp up into high performance mode. As soon as I close Media Center the card ramps up. I can literally be playing Diablo 3 while watchign TV (love watching the NBA finals while I game) and the card will stay at 500mhz. If I alt+tab out of the game, close media center and go back in, the card immediately ramps up to full speed. I've had this issue since I got my 7950 and havent found a work around.
Score
0
June 20, 2012 2:24:15 PM

AdioKIP said:
Do you have any other programs running while playing the games. I have the exact same issue (Radeon 7950) BUT I managed to isolate it and figured out, Windows Media Center is causing it for me. If I have Media Center open the video card wont ramp up into high performance mode. As soon as I close Media Center the card ramps up. I can literally be playing Diablo 3 while watchign TV (love watching the NBA finals while I game) and the card will stay at 500mhz. If I alt+tab out of the game, close media center and go back in, the card immediately ramps up to full speed. I've had this issue since I got my 7950 and havent found a work around.


Have any of you tried comparing tests with hardware acceleration enabled and disabled? That might be causing issues too.
Score
0
June 20, 2012 2:42:07 PM

Hardware acceleration disabled where? I've looked thru Media Center and cant find any options within the program to disable hardware acceleration. Is there an option in CCC to disable and if so can I only do it for certain programs?
Score
0
June 20, 2012 5:41:10 PM

blazorthon said:
I never said that for Corsair. Corsair sells excellent PSUs. Cooler Master is known to not make their own PSUs and that they re-brand less than ideal PSUs. This is why Cooler Master often has more efficient, modular power supplies (among several other companies who do similar work in the PSU market to Cooler Master) at lower prices than the better brands, such as Corsair, Antec, and Seasonic.

Oh, I see. I had no idea Cooler Master didn't make their own PSUs. That said, I still think 700w should be enough for my setup. Yes, when I uninstall my drivers I completely uninstall all AMD/Ati graphics drivers (and all other related software) then reboot.
AdioKIP said:
Do you have any other programs running while playing the games. I have the exact same issue (Radeon 7950) BUT I managed to isolate it and figured out, Windows Media Center is causing it for me. If I have Media Center open the video card wont ramp up into high performance mode. As soon as I close Media Center the card ramps up. I can literally be playing Diablo 3 while watchign TV (love watching the NBA finals while I game) and the card will stay at 500mhz. If I alt+tab out of the game, close media center and go back in, the card immediately ramps up to full speed. I've had this issue since I got my 7950 and havent found a work around.

I figured it would be something simple like that, however, I do not have Media Center running so my issue must be another program running in the background. I do of course run other programs in the background because I have a dual monitor setup.
Score
0
June 20, 2012 9:35:24 PM

i_pk_pjers_i said:
Oh, I see. I had no idea Cooler Master didn't make their own PSUs. That said, I still think 700w should be enough for my setup. Yes, when I uninstall my drivers I completely uninstall all AMD/Ati graphics drivers (and all other related software) then reboot.

I figured it would be something simple like that, however, I do not have Media Center running so my issue must be another program running in the background. I do of course run other programs in the background because I have a dual monitor setup.


I run a 4 monitor setup so am constantly multi-tasking, even during games. So far Windows Media Center has been the only program I've seen cause this. I have a logitech G19 Keyboard with the LCD screen and use it to monitor my system stats so can see right away when there is a change in clock speed. Not sure why Media Center wont let the card ramp up but any other programs seem fine. I can run 1080p video on my left screen with VLC Player, another video on the right with windows media player and still game on the middle screen just fine with the card ramping up. As soon as media center is in the mix the card wont ramp up. I even went so far as to try different TV software, I tried the manufacturers (hauppauge) program. While it didnt seem to stop the video card from ramping up, the live tv stream seemed to freeze everytime I would start a game of Diablo.

We did the same upgrade (5850 - 7950) and now have the same problem. For me I know its software related, most likely yours is as well. Check whatever programs you have running the background. Make sure the Windows Media Center program guide thing isnt on (runs in the background sometimes).
Score
0
June 20, 2012 10:16:54 PM

AdioKIP said:
I run a 4 monitor setup so am constantly multi-tasking, even during games. So far Windows Media Center has been the only program I've seen cause this. I have a logitech G19 Keyboard with the LCD screen and use it to monitor my system stats so can see right away when there is a change in clock speed. Not sure why Media Center wont let the card ramp up but any other programs seem fine. I can run 1080p video on my left screen with VLC Player, another video on the right with windows media player and still game on the middle screen just fine with the card ramping up. As soon as media center is in the mix the card wont ramp up. I even went so far as to try different TV software, I tried the manufacturers (hauppauge) program. While it didnt seem to stop the video card from ramping up, the live tv stream seemed to freeze everytime I would start a game of Diablo.

We did the same upgrade (5850 - 7950) and now have the same problem. For me I know its software related, most likely yours is as well. Check whatever programs you have running the background. Make sure the Windows Media Center program guide thing isnt on (runs in the background sometimes).

I have the problem more now today than yesterday yet I am running the exact same programs. It won't even apply the overclock now, it just does 830MHz core speed instead of 930MHz no matter what game I play. I honestly do not know what software could be causing this, I don't think any of my software could be to be honest. I do not have windows media center running or even have it as a startup service.
Score
0

Best solution

June 20, 2012 10:47:48 PM

i_pk_pjers_i said:
I have the problem more now today than yesterday yet I am running the exact same programs. It won't even apply the overclock now, it just does 830MHz core speed instead of 930MHz no matter what game I play. I honestly do not know what software could be causing this, I don't think any of my software could be to be honest. I do not have windows media center running or even have it as a startup service.


i have manage to regenerate the 501mhz problem by running flash based video like from youtube or something similar. what does your gpu usage graph look like. also when your running all your usual programs other then games how does your temps look like?
Share
June 20, 2012 11:02:37 PM

zakattak80 said:
i have manage to regenerate the 501mhz problem by running flash based video like from youtube or something similar. what does your gpu usage graph look like. also when your running all your usual programs other then games how does your temps look like?

That fixed it, thank you so much. My power supply was NOT the cause of the problem and did not contribute to it one bit. I just KNEW it had to be software related and not hardware related. Running flash video whilst playing games caused high-performance mode to not activate on my 7950, when I do not have flash video running it activates just fine and I can get the frames per second in games that I should be getting. There is two possible fixes for the flash video, 1) you can stop watching flash video entirely whist playing games or 2) you can right click flash video and click disable hardware acceleration, either will allow high-performance mode to be activated when you are playing a game. I hope this helps anyone else who was having this problem. This can now be closed or whatever. Again, thank you so much for fixing my problem.
Score
0
June 20, 2012 11:48:23 PM

i_pk_pjers_i said:
That fixed it, thank you so much. My power supply was NOT the cause of the problem and did not contribute to it one bit. I just KNEW it had to be software related and not hardware related. Running flash video whilst playing games caused high-performance mode to not activate on my 7950, when I do not have flash video running it activates just fine and I can get the frames per second in games that I should be getting. There is two possible fixes for the flash video, 1) you can stop watching flash video entirely whist playing games or 2) you can right click flash video and click disable hardware acceleration, either will allow high-performance mode to be activated when you are playing a game. I hope this helps anyone else who was having this problem. This can now be closed or whatever. Again, thank you so much for fixing my problem.


awesome, enjoy the card. that well help me since i like listening to youtube lectures about various things while i play some games, but never did since my games wouldn't run as fast as i wanted it to.
Score
0
June 21, 2012 12:24:43 AM

Glad you found a fix, but does anyone know how to disable hardware acceleration in windows media center? I would love to be able to watch live tv and still have the video card go up to full speed.
Score
0
June 21, 2012 12:31:37 AM

AdioKIP said:
Glad you found a fix, but does anyone know how to disable hardware acceleration in windows media center? I would love to be able to watch live tv and still have the video card go up to full speed.


http://www.pixelmetrics.com/Tips/VidBlank/MediaPlayer.p...

You could give that a try.
Score
0
June 21, 2012 12:25:02 PM

AdioKIP said:
Thanks, but this refers to Media "Player", not Media "Center". I dont seem to have the issue when playing video in media player, the issue only occurs when using Media "Center".


http://www.deskshare.com/Resources/articles/dmc_turnoff...

This is how to disable it system-wide. It says that it's XP, but the method is pretty much identical for 7/vista/8.
I'm still looking for a way to disable it only in Windows Media Center, but I'm having a little more trouble with this one. Maybe you could try using a freeware third-party media program?
Score
0
June 21, 2012 1:02:39 PM

Using your original link led me to gogling some information, I did find instructions for dialing down or turning off acceleration in Windows 7, however the option is grayed out as if my video drivers dont support it. (Using 12.4 drivers).

I've tried other programs for TV viewing (last time was specifically for this issue). The other programs simply seem to pause/freeze the tv display anytime I start a game.

Instructions I found:
Step 1:

To decrease hardware acceleration on your computer, perform the following steps:

1. Click Start, select Control Panel, click Appearance and Personalization, click Personalization, click Display Settings, and then click Advanced Settings.

2. Click the Troubleshoot tab, and then click Change Settings.

Note: Change Settings will be disabled if the graphics card drivers do not support disabling hardware acceleration.

3. Move the Hardware Acceleration slider until it is one notch to the right of none. This is the basic acceleration setting.

4. Click OK twice, and then close the window.
Score
0
June 21, 2012 1:13:52 PM

OK I remember that process there. You might be able to disable hardware acceleration if you uninstall your AMD graphics drivers and use the default Windows driver when you try to disable it. After you do this and disable acceleration, you can then re-install your graphics driver and it should still be in effect. Keep in mind that this is system-wide and not just for Media Center. Also, you could try a driver update to Catalyst 12.6 and see if it helps.
Score
0
June 21, 2012 2:41:03 PM

I was waiting for the official 12.6 rather than the beta. As soon as its released I'll give it a try. Overall I dont want to make the change system wide. Everything else seems to work fine with hardware acceleration on, and even when not gaming I see spikes in my video card usage so I know its being utilized which is a good thing.
Score
0
June 21, 2012 2:48:18 PM

AdioKIP said:
I was waiting for the official 12.6 rather than the beta. As soon as its released I'll give it a try. Overall I dont want to make the change system wide. Everything else seems to work fine with hardware acceleration on, and even when not gaming I see spikes in my video card usage so I know its being utilized which is a good thing.


Your choice, but the 12.6 beta is considerably more stable than the previous official releases and has other advantages. Even if you don't want to stick with it, you could at least give it a try and see if it helps. That might give you an idea about whether or not the official 12.6 will help or not right now instead of waiting (who knows how long?) for it to come out.

You might see spikes in GPU usage, but are you making comparisons of the performance of applications that cause those spikes between with and without hardware acceleration? You might find that the difference is not worth the trouble (of course, you might also find that the opposite is true).
Score
0
June 25, 2012 6:52:05 AM

Best answer selected by i_pk_pjers_i.
Score
0
July 8, 2012 2:40:02 AM

blazorthon said:
Your choice, but the 12.6 beta is considerably more stable than the previous official releases and has other advantages. Even if you don't want to stick with it, you could at least give it a try and see if it helps. That might give you an idea about whether or not the official 12.6 will help or not right now instead of waiting (who knows how long?) for it to come out.

You might see spikes in GPU usage, but are you making comparisons of the performance of applications that cause those spikes between with and without hardware acceleration? You might find that the difference is not worth the trouble (of course, you might also find that the opposite is true).


Just following up, while the 12.6 drivers seem to work great for gaming, the issue is still there. Anytime windows Media center is open the graphics card wont go into high performance mode. Any program besides Media Center playing video seems fine. I can play diablo in EyeFinity on 3 screens at 5760x1080 while playing 1080p video on my 4th screen using VLC or media player, its just something with media center.
Score
0
July 8, 2012 3:06:56 PM

AdioKIP said:
Just following up, while the 12.6 drivers seem to work great for gaming, the issue is still there. Anytime windows Media center is open the graphics card wont go into high performance mode. Any program besides Media Center playing video seems fine. I can play diablo in EyeFinity on 3 screens at 5760x1080 while playing 1080p video on my 4th screen using VLC or media player, its just something with media center.


Might want to just not use Media center if that's the case. Also, 12.6 has a full release and 12.7 is the current beta now and 12.7 is a performance boosting release.
Score
0
July 8, 2012 4:43:32 PM

This topic has been closed by Mousemonkey
Score
0
!