Sign in with
Sign up | Sign in
Your question

Computer doesnt start at all

Last response: in CPUs
Share
December 26, 2012 12:26:07 PM

So yesterday we had a power outage, while i was using my computer. But after the power came back, my computer wouldnt turn on at all. When i press the power button nothing happens. I tried testing my PSU by connecting it only to the ventilator and it worked, so im assuming its not PSU. Also the lights on the motherboard are also shining (on/off and reset).

My computer specs are: motherboard ASUS P6T, RAM Mushkin 6GB 1600MHz (3x2GB), HD WD Black 1T and 640 GB, processor i7 920, graphic card ATI RADEON 4870x2 2GB, case ANTEC 1200 Ultimate and PSU LC Power 850W arkangel.

All help appriciated.

More about : computer doesnt start

December 26, 2012 7:25:06 PM

malahorna said:
So yesterday we had a power outage, while i was using my computer. But after the power came back, my computer wouldnt turn on at all. When i press the power button nothing happens. I tried testing my PSU by connecting it only to the ventilator and it worked, so im assuming its not PSU. Also the lights on the motherboard are also shining (on/off and reset).

My computer specs are: motherboard ASUS P6T, RAM Mushkin 6GB 1600MHz (3x2GB), HD WD Black 1T and 640 GB, processor i7 920, graphic card ATI RADEON 4870x2 2GB, case ANTEC 1200 Ultimate and PSU LC Power 850W arkangel.

All help appriciated.


On your motherboard, find where the power button cable connects to the motherboard (most probably looks like a small black rectangle that plugs into two pins)
Remove the connector and with a screwdriver touch the two pins simultaneously to make a connection.
If it works then it's the power cable/button which is busted.
!