Solved

Strange speaker noise from new build pc

Hello,
so my problem is that my speaker has no other sound but a strange noise when i plug it into my new build pc(front or rear jack), its a cm elite 311 casing, asrock h77m mobo and running windows 7 64bit.

i tried the speaker on my macbook and it worked just fine. i also reformatted my windows but the sound are still there.

i plugged in another old speaker to the pc and it also has the same problem(strange noise).

is it the motherboard audio jack or somewhat are causing this? the speaker was working fine on the new build pc before(using intel hd graphic) and after a long day i was messing with the graphic card (some problem) and finally get the graphic card to work then when i turn on my pc again it has this problem... it is really frustrating and double face palm... would buying a cheap external sound card fix this? pls help anyone?
8 answers Last reply Best Answer
More about strange speaker noise build
  1. External sound card would work I had the same problem as you. Maybe try your front speaker out
  2. Also try another port on the back of your mobo because you can set all of them to outputs sound (that fixed it for me)
  3. i tried the front panel but still had the problem, no sound just noise, and how to set the port like u said? thanks for reply
  4. If you plug the speakers/headphones into the mic in on the back of your mobo is it the same noise? Or is there no sound at all? I think it's the pink one? Not to sure tho. If not then update your drivers from your mobo's website and if that dosent work get a new sound card because obviously your Realtek sound chip is blown or get a USB to audio adapter :bounce:
  5. User4798 said:
    If you plug the speakers/headphones into the mic in on the back of your mobo is it the same noise? Or is there no sound at all? I think it's the pink one? Not to sure tho. If not then update your drivers from your mobo's website and if that dosent work get a new sound card because obviously your Realtek sound chip is blown or get a USB to audio adapter :bounce:

    i formatted my pc so it should't be the driver problem and so far all the port also had that problem
  6. Best answer
    oh so i think the only option you have is getting a usb to audio adapter or a sound card.
  7. hey do you have audio on your screen? also go to ccc or nvidia control centre and disable and audio setting then try back port again. if that dosent work plug the speaker into your screen (if it has a port) and enable all audio settings in control centre. the screen should work (if it has a port) and ir runs of your gpu witch is very good.
  8. Best answer selected by 0412041.
Ask a new question

Read More

Sound Cards Speakers New Build Components