Sign in with
Sign up | Sign in
Your question
Closed

670M (MSI GT70) - games running very poorly, low framerate

Last response: in Graphics & Displays
Share
June 22, 2012 2:10:18 AM

Hello everyone,

I just bought a GT70 and apart from the low FPS, it's pretty awesome. But I need to be able to game on a laptop that's marketed as a gaming laptop.

I don't expect desktop performance, but I don't think I should be getting ~20 FPS in every game.

For instance, World of Warcraft runs at around 14-16 FPS. Diablo 3 hasn't reached 25 FPS and some other games have been running like that.

Even games that should run amazingly, even by mobile graphic standards, are achieving very poor performance.

Any tips guys?

I've looked around and I've seen suggestions, but nothing has helped.

What I've tried:

Updating Drivers, Rightclicking the application and setting confirming that nVidia is selected (it's been the default selection for all games thus far), running off AC power.

Any help would really be appreciated as I do want to play on this thing.

Thanks in advance.
June 22, 2012 2:33:47 AM

have you changed the power settings to high performance without that setting it will throttle the cpu and video card.
Make sure turbo boost is on and if your framerate is suffering you might want to turn the resolution down a bit as most games default at 1920 x 1080 try 1680 x 1050.

The video card is the bottleneck unfortunately mobile video cards just don't pack that much power compared to desktop.
Score
0
June 22, 2012 3:48:28 AM

I don't think it's a resolution issue, though. Before I bought this laptop, I had an ASUS with a 650M that was exchanged (due to faulty speakers) and D3/WoW ran without a hitch. D3 wasn't sluggish at with AA off and and WoW just as well as my 570 from my desktop.

I turned all the settings down to minimal in D3 (while keeping the 1920x1080) and it maybe increased FPS by 5 on average, though still struggling quite a bit. Even while signing into the game, I notice the button clicks are very sluggish and lag even. Even at 1920, the game should be running at least acceptably with all the settings down. The game is practically unplayable though.

I honestly think the games are running off the Intel graphics even though nVidia GPU Activity monitor shows the game is using it, but I'm not convinced.

At this point I'm starting to wonder, is this computer faulty?

Quick Edit: I just did an Index performance test and achieved a 5.3 rating for the GPU, and I know I know don't go by the Index, but Notebook Check shows that I should be achieving much higher, almost max even. That review basically confirms that this laptop should be running without issue. I don't know what is up.
Score
0
Related resources
June 22, 2012 4:11:48 AM

What are your system specs?
Score
0
June 22, 2012 4:12:26 AM

techguy911 said:
have you changed the power settings to high performance without that setting it will throttle the cpu and video card.
Make sure turbo boost is on and if your framerate is suffering you might want to turn the resolution down a bit as most games default at 1920 x 1080 try 1680 x 1050.

The video card is the bottleneck unfortunately mobile video cards just don't pack that much power compared to desktop.


I have a 310m and I can run WoW on Ultra at 30 fps.
Score
0
June 22, 2012 4:24:05 AM

hey why dont you make sure that you have installed the latest drivers for all your components.....
Score
0
June 22, 2012 4:27:04 AM

Yeah something is wrong. My gf can rung Diablo 3 maxed on a GT555m at 1080p

Have you made sure it's on performance mode in the nVidia Control Panel and not Adaptive (this throttles it down). Do you have GPU-Z? If so can you give us some numbers like gpu usage, heat etc.
Score
0
June 22, 2012 11:23:02 AM

Sound like your going through the video built into the cpu there is a program called Virtu MVP that switches from onboard to mobile video card or links them together for more power.
Sound like it's set to the gpu onboard the cpu only if you can't find Virtu MVP try downloading the new version and make sure the 670M is set as output.
MSI has just changed the video card to a 675M GPU in that model sound though like your nvidia setting might not be on performance you might want to check that as well.

http://www.lucidlogix.com/product-virtu-mvp.html

There is a feature called Optimus it switches from ivybridge gpu to the 670M you might want to check that and see if it's set to 670m on ac there is a developers tool that shows what gpu is being used try that while it's running.

http://www.youtube.com/watch?v=Zh4HCadTY_A
NVIDIA Optimus Driver Tutorial
Score
0
June 22, 2012 2:44:03 PM

panwala95 said:
hey why dont you make sure that you have installed the latest drivers for all your components.....


I was starting to download updated drivers from the MSI website, but nVidia wouldn't allow me to install the driver (I double checked, it was the right one) saying it wasn't compatible with my hardware. I think there might be something up with the whole OS installation. I'm going to try a few more things before I give up and format/install. If that doesn't help I'll just need to return it.

techguy911 said:
Sound like your going through the video built into the cpu there is a program called Virtu MVP that switches from onboard to mobile video card or links them together for more power.
Sound like it's set to the gpu onboard the cpu only if you can't find Virtu MVP try downloading the new version and make sure the 670M is set as output.
MSI has just changed the video card to a 675M GPU in that model sound though like your nvidia setting might not be on performance you might want to check that as well.

http://www.lucidlogix.com/product-virtu-mvp.html

There is a feature called Optimus it switches from ivybridge gpu to the 670M you might want to check that and see if it's set to 670m on ac there is a developers tool that shows what gpu is being used try that while it's running.

http://www.youtube.com/watch?v=Zh4HCadTY_A
NVIDIA Optimus Driver Tutorial


Thanks for this, I'll be giving this a shot before I try formatting and such.
Score
0
!