Sign in with
Sign up | Sign in
Your question

BIOS stopped recognizing Hard Drive

Last response: in Components
Share
December 27, 2012 10:50:58 PM

The computer is a Gateway NV79 laptop with a Seagate Momentus 5400.6 SATA Hard Drive. OS is Windows 7 Home, 64 bit. A few days ago a message can up at boot up saying "no boot devices found, please insert bootable disk". So I checked the BIOS and noticed that my hard drive was not listed anywhere, the spot where it should of been was blank but it did recognize my DVD drive with all the correct info. I took my hard drive out, attached it to another computer and it worked fine and I was able to backup all my files. I plugged it back in and got the same mesage. I then took the motherboard battery out to reset the BIOS, still no luck. I then looked for a BIOS upgrade and still no luck.i I even tried hooking up a completely different Hard drive and still no luck. I'm now assuming something is wrong with the Motherboard but was wondering if you had any suggestions that I may have missed?

Thanks,
Vinny
December 27, 2012 11:10:43 PM

It might be a problem with powering the HDD. You can try using an external HDD enclosure.
December 27, 2012 11:32:22 PM

Looks like you have a disabled or broken disk controller on the board but first try a different power connector from your PSU. Both drives SATA?
Related resources
December 27, 2012 11:36:50 PM

It's a laptop.
December 27, 2012 11:38:07 PM

Missed that part but most likely motherboard issue then.
December 27, 2012 11:39:01 PM

It seems so.
December 27, 2012 11:42:26 PM

From the gateway website
Only "Hard Drive not found" or "Missing hard drive" error messages conclusively indicate a hard drive has not been detected. Other symptoms could be a result of bad hard drive data or BIOS boot order settings.
December 27, 2012 11:49:12 PM

alexoiu said:
It might be a problem with powering the HDD. You can try using an external HDD enclosure.

Thanks for the suggestion...

Do you mean a powering problem from the connection on the motherboard in my laptop? because I took the hard drive out and hooked it up to my desktop through a USB hard drive adapter I have and it worked fine and I was at least able to copy all my files to my desktop so I have them backed up.

I'll give it a try through my laptop and tell you if it worked or not. Thanks for the suggestion
December 28, 2012 12:01:42 AM

Yes, a problem with the motherboard (not providing power to the HDD). Not sure also if it's a connection issue or more than that. Check if in BIOS there's an option for booting from a removable device. If yes, then most probably you can use the enclosure.
Is the laptop still under warranty?
December 28, 2012 12:04:02 AM

It worked when i connected it through a external USB enclosure and set it as the 1st boot in the BIOS so it must be the motherboard which really sucks. Thanks for everyone's help and all of your quick responses, i greatly appreciate it.
December 28, 2012 12:27:44 AM

I'm new to this site and I'm pretty impressed at how fast all of you responded to my problem, thank you. I greatly appreciate it and will definitly use this site in the future. Other sites like these usually take days to get a response. Thanks again for all your help
!