Sign in with
Sign up | Sign in
Your question

CM quickfire keyboard not responding

Last response: in Components
Share
December 28, 2012 8:08:51 PM

I just purchased a CM storm quick fire pro gaming keyboard but I can not get my windows 7 desktop to recognize it. I know the keyboard works and that the wire is plugged into the board correctly because I tried plugging it into a old macbook pro and it immediately lit up and worked fine. The motherboard is a "asus sabertooth 990fx" I tried it in both the USB 3.0 and 2.0, and I have never had any trouble with any of the USB ports from the motherboard. The keyboard also works when I first boot into a Linux Gnome screen but after selecting windows it stops responding. One time the computer did recognize that something was plugged in and I got a message saying windows could not install the drivers properly. Any suggestions would be very helpful, and I apologize if this is posted in the wrong section of the forum.
December 28, 2012 8:25:47 PM

Never mind I got it working.
m
0
l
December 10, 2013 5:56:38 PM

icebeast42 said:
Never mind I got it working.


How did you get this to work? I'm having the same issue.
m
0
l
December 12, 2013 8:55:56 AM

I know this is an old thread but I wanted to update in case anyone else has this issue and comes across this thread.

I have a Gigabyte GA-990FXA-UD3 Rev. 1.1 and was having the same issue as the original poster. To fix the issue, I updated my USB 3.0 drivers and plugged the keyboard into a USB 3.0 slot. It will still not work in any of the USB 2.0 slots but that's okay with me as long as it works. Hope this helps.
m
0
l
!