Sign in with
Sign up | Sign in
Your question
Solved

Stumped.....internet connectivity and network adapter

Last response: in Systems
Share
August 14, 2012 9:23:47 PM

Last night after work, I lost my internet connection. My internet provider is not so great, so I called them...after 30 minutes, I was able to determine that it wasn't an outage.

I was also able to isolate the problem to my computer. I'm able to get a connection through my router to my wireless devices, but can't get my computer connected through an ethernet cable. The PC Activity light on the router is not lit. Also, the activity light on the network adapter is constantly lit, not blinking. Also, the windows diagnostic just tells me that my cable is not plugged in correctly. I've swapped out a few cables to make sure they're not bad.

So far, I've reset the adapter by disabling and enabling it, checking for driver updates, and re-applying the drivers from the mobo manufacturer's disk (GIGABYTE). Nothing's worked.

I'm stumped. Any help would be appreciated.
a b B Homebuilt system
August 14, 2012 9:33:28 PM

Can you try another PC to determine if the issue is with the router, the cable (did you test it or use a different cable) or the PC?
August 14, 2012 9:38:00 PM

Just tested the setup with my laptop and it works. So it's not the cable or the router.
Related resources
a b B Homebuilt system
August 14, 2012 9:43:02 PM

What motherboard do you have? Did you disable and enable the LAN controller in the BIOS or in the OS? I would disable it in the BIOS, reboot, enable it again, etc.
August 14, 2012 9:47:56 PM

I'm using a GIGABYTE GA-Z68A-D3H-B3. I'll try that and let you know what happens.
a b B Homebuilt system
August 14, 2012 9:51:23 PM

You could also boot from a Linux DVD to determine if there's an issue with your OS configuration.
August 14, 2012 10:02:54 PM

Disabling, booting, and enabling the LAN controller from the BIOS didn't fix anything.

Best solution

a b B Homebuilt system
August 14, 2012 10:40:29 PM
Share

You should reset the motherboard to it's default settings (after making sure that you documented the current settings, including the SATA controller). Then boot Windows and see what happens. If that doesn't work, then boot from another OS to verify if the LAN controller went bad or not. If another OS like Linux can access the Internet, then you know that the LAN controller works fine.

Last night did you install new hardware, software or updates?
August 14, 2012 11:33:57 PM

No hardware or software. Not sure if it updated. I'll have reset the motherboard later. Need to go for the night. What would I need to do if the LAN controller went bad?

I'll keep you updated. Thanks for the help!
a b B Homebuilt system
August 15, 2012 1:33:40 AM

If it went bad, then you could RMA the motherboard if it still is under warranty or you can add a PCI or PCIe LAN card.
August 15, 2012 2:29:31 AM

Ahh....good call. The mobo is definitely NOT still under warranty, but I didn't think of a PCI card.
August 15, 2012 10:32:39 PM

Hey, just wanted to let you know that I got it working! After a little more research online, I heard of some people unplugging their systems and draining the capacitors on the mobo with the power switch. After doing that, everything's back up and running! Thanks for the help and support!
August 15, 2012 10:33:15 PM

Best answer selected by Rampancy11.
August 15, 2012 11:23:43 PM

Sigh...false alarm. It's messed up again. After doing the steps above, it worked for a little while but then stopped again. On top of that, my second monitor, the one plugged into the onboard graphics (not my graphics card), now has a yellow tint. Does this mean that the whole motherboard is dying?

This whole thing has me so frustrated....I really don't understand how it can work one minute and not the next. This is seeming more and more like a hardware problem. I've located a spare PCI network card, but what does that flickering/off-color monitor mean? Can't be good.
a b B Homebuilt system
August 16, 2012 12:37:49 AM

You normally reset the CMOS by disconnecting the PSU from the outlet and then remove the battery for several seconds.

If the LAN controller worked and then stopped working, check for a heat issue. Is the motherboard in a properly ventilated case? Does the second monitor work fine when connected to the graphics card?

I'd still test the system with a bootable DVD to make 100% sure that the OS isn't causing the issue.
August 16, 2012 4:02:02 AM

Problem is, I don't have a bootable DVD to test with. I've got the monitor issue resolved, but the LAN controller still only works for 20-30 minutes at a time after shutting down and draining power. Removing the battery is going to be my next move....but it doesn't really seem like it makes sense that resetting the CMOS would help if it actually works for awhile.

I've been running this setup for almost a year and have never had an issue with heat. Nothing is particularly dirty, case is pretty well ventilated, and i'm getting OK readings through my temperature monitors. Would there be any other possible reason it would fail after some time passes? I'm so confused because nothing besides heat makes sense to me, but heat doesn't seem to be the problem.

a b B Homebuilt system
August 16, 2012 12:46:22 PM

Does it work when the PC has been powered off for long enough to be cold? If so, then you could leave the side panel open and use a fan to blow air towards the motherboard. It really doesn't make sense to have to drain power to make it work.

If heat isn't the issue, you can download a Linux bootable CD from ftp://mirrors.kernel.org/knoppix/. The CD image ADRIANE-KNOPPIX_V6.7.0CD-2011-08-01-EN.iso should be enough for your test. Once downloaded, burn the image with ImgBurn or whatever tool you prefer. The primary goal of booting another OS is to determine if something in Windows is causing that issue. Once the LAN controller fails, you boot from the CD and then try to access the Internet.
August 16, 2012 9:46:56 PM

The reason I mentioned draining the power is because when it first started giving me problems, I shut the computer down for the night, but didn't unplug it. The next morning, it still didn't work. Only after I tried draining the power and resetting everything did I get any signs of life out of it.

I don't know if that was maybe just a coincidence or what, but I was just going off what seemed to work....at least temporarily. I've also been able to replicate that sequence of events multiple times now: Fails, shutdown, drain power, wait, starts back up and works again. After about 20-30 minutes, it usually fails again.

I still haven't been able to properly reset the CMOS yet....haven't had time. I'll try that, and assuming that doesn't work, I'll move on to burning a boot disk. Thanks again for sticking with me through this. I really appreciate it.
!