Sign in with
Sign up | Sign in
Your question
Solved

CCC and Crossfire problems

Last response: in Graphics & Displays
Share
June 25, 2012 9:56:50 PM

I'm having problems with my Crossfire setup (two HD 6850 cards) as well as CCC. I had been having fan problems on one of my GPUs, so I ordered an aftermarket cooler for it and it arrived today. I found out after opening it that it did not fit my card like it advertised. That, however, isn't a problem.

The problem is that when I put my card's case and stock fan back together with the card itself, put it back to my computer and booted it up, it immediately took me to the BIOS (Asus motherboard), and I didn't press anything to direct it there. Since I have no idea what to do in BIOS, I just exited and booted up normally. When I got to my desktop, though, I noticed my GPU temp gadget (not related to CCC or AMD) was out of whack, and it didn't seem to be recognizing that I have two cards. When I opened CCC, not only was it back to my previous version (12.3, when I had updated to 12.4 a few days ago), but it wasn't giving me any option for Crossfire setup. Usually, under the Performance tab on the left side of CCC, it will have AMD Crossfire and AMD Overdrive. Now, there is only AMD Overdrive. Crossfire is nowhere to be found.

I opened my case back up, thinking I hadn't put the card back in correctly, so I took it out, put it in again making sure it was seated 100% perfectly and everything was perfectly plugged in. I booted up and got back to my desktop, and while it seems like my GPU gadget is working fine again, CCC is still not recognizing that I have a Crossfire setup.

For the record, I have been running this same setup for over a year now, and it's never done this before. Furthermore, I loaded up The Witcher 2, which I normally run with everything except Ubersampling on max, and it played perfectly fine, which it definitely wouldn't do if my mobo was only recognizing one card.

One last thing....I also tried to update CCC to 12.4 again, and both times, it finishes the update but is still stuck at 12.3.

If anyone has any ideas or advice, PLEASE let me know, because I'm in the dark here. I really have no idea what's changed since before I took the card out and put it back in.

More about : ccc crossfire problems

Best solution

June 25, 2012 10:28:20 PM

1) Make sure bridge is on
2) Download Driver Sweeper here.
3) Download Catalyst 12.6beta drivers here but don't install.
4) Custom uninstall AMD software and select everything and reboot.
5) Run Driver Sweeper and clean AMD drivers and reboot.
6) Re-install CCC and reboot.
Share
June 25, 2012 11:36:12 PM

Best answer selected by jthamind.
m
0
l
Related resources
June 25, 2012 11:37:51 PM

Thank you so much, Russ!! I followed all of your steps, and now my CCC is working fine. :) 

Now, I just need to find a good aftermarket GPU cooler for my XFX HD 6850. any suggestions? I contacted XFX and they said they were out of stock of replacement fans, and the bearing on mine seems to be coming loose (it's making buzzing noises as it's spinning), but at least it's still working. I do want to replace it before it completely screws up, though.
m
0
l
June 26, 2012 12:08:47 AM

That's actually the one I ordered that doesn't seem to fit, even though it's advertised to. The connectors from the fan are three and four pin ones, but the one on my GPU is a two pin one. Unless there's something I'm doing wrong?
m
0
l
June 26, 2012 12:39:42 AM

I actually saw in one of the comments on amazon that somebody said he also only had a 2 pin connector, so he had to use an adapter that came with the cooler and plug it directly into the power supply.

Is that something I could do? I have a friend telling me no, even though i see a free cable that I could plug it into that comes from my power supply.
m
0
l
June 26, 2012 12:41:16 AM

Ok, thanks, I'll do that. :) 
m
0
l
June 26, 2012 12:45:38 AM

NP... good luck! and remember, if it doesn't fit it doesn't belong there.
m
0
l
!