Sign in with
Sign up | Sign in
Your question

Unique Problem (Games shutdown PC after 2nd play)

Last response: in Components
Share
December 30, 2012 8:18:02 AM

This problem is almost comical but I do want to get it resolved. You guys are going to get a kick out of this.

<b>Background</b> : I was playing Far Cry 3 (great game btw) about 2 weeks ago and boom, PC loses power. I did some troubleshooting and it lead me to believe it was the PSU that was fault. The paper clip trick confirmed this. I go out to buy a new PSU but my options are limited ( I am in a small town in South Korea) but I end up picking one up that is 600w with 2 12v rails that push out 25amps on each rail. I get it installed at it boots right up and I finish the game.

Now I did have a little accident with the CPU pins, I had to bend them back and try a few times before I finally get the PC to post. I think this has something to do with my problem but I will let you decide.

<b>Problem</b> : Now I have installed 3 games in the last 2 weeks : Arkham City, Ghost Recon: Future Soldier, and SWOTR. They all are having the same SUPER WEIRD problem: after the first install (launch the game after installation) I can play the game fine. But as soon as I close the game and come back to open it up, ALL of the games crash my PC after the loading screens. By loading screen I mean once all the advertisements play and I have to option to "Press any key" or "Start Game". I can however play Counter-strike (installed before this problem)

I have monitored the GPU and CPU temps, they are perfectly fine. I can alt tab away from the screen right before the "loading" screen and do anything on my PC but as soon as I press that button my PC loses all power. I have updated the GFX drivers as well as the bios. I've ran prime95 and furmark and my PC doesn't crash. I have checked the health of my SSD (64%, not sure if that's relevant). Any ideas?

<b>Specs</b> :
AMD 1055T
Zotac GTX 560 Ti AMP Edition
4 gigs G Skill PC-12800
Gigabyte GA-970A-D3
HANA Micron 128gb SSD


December 30, 2012 8:40:36 AM

Ok, dunno, but set everything to "Run As Administrator". Installs from DVD's /CD's usualy run as admin(and if you run the game from the install tab after finishing the instal it maybe ran as admin). If your games are pirated...i dont wanna give any advice then :) 
December 30, 2012 8:42:14 AM

I have tried that. I right click > run as admin as well as check the box in properties. And no piracy here! <3
Related resources
December 30, 2012 8:52:40 AM

I just tried it again to confirm crisan_tiberiu. It's rather cute how my PC dies. No loud noise, no fan spin up. Just instant death.
December 30, 2012 11:19:45 PM

I tried rolling back the drivers to a previous version but I still get the same problem.
!