[Help] Bios worked but no video after?

Hello. First time computer builder in need of answers and/or help. But before everyone jumps on my case, I followed the vast majority of this thread sans disassembling it. http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems


My build is as follows

Intel Core i5 3570K
Biostar TZ77A LGA 1155 Z77
G.SKILL Value Series 8GB
Antec NEO ECO 620C 620W Continuous Power
SONY Black SATA DVD-ROM Drive
GIGABYTE GV-N670OC-2GD GeForce GTX 670 2GB
Fractal Design Core 3000
SAMSUNG Spinpoint F3 HD103SJ 1TB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive


What part confused me, is that prior to the "No Video Output" showing up on my screen, I was able to boot Bios up and make changes to the time/date. After that, I've been unable to do anything BUT see the "No Video Output" screen.

I'm under the impression it might be my video card, but that wouldn't explain why I was able to boot Bios up (unless your video card plays no part in Bios, in which case you have my permission to fire away).

I'm less looking for solutions, and more for explanations which might be conductive to those solutions, but any advice would be much appreciated.
5 answers Last reply
More about help bios worked video after
  1. Yea, video card doesn't affect the BIOS. I think the problem is with the GPU power. Make sure it is FIRMLY seated in the PCIe slot. It takes a bit of force to seat it. In fact, the 1st time I installed my GPU, I was surprised at the force needed for it to be firmly seated. Then, make sure the PCIe power connectors are firmly attached to the GPU.
  2. Took out and plugged the GPU power.

    No luck, unless I'm doing the total wrong thing, which wouldn't surprise me.
  3. Most of the time it's not a hardware issue, but human error. So, if we rule out human error, it's easier to diagnose. Also, make sure the PSU is plugged into the power cable, and that the power cable is plugged into the outlet. Make sure the red switch on the back of the PSU is set to the outlet of your voltage. If it is already, do NOT switch it.
  4. -make sure the PSU is plugged into the power cable
    Yes
    - the power cable is plugged into the outlet.
    Of course
    -the red switch on the back of the PSU is set to the outlet of your voltage
    This much I don't understand
  5. Nevermind. Some PSU's have that option, but looking at product pics, yours doesn't. It's probably a problem with the GPU, but if not, then the PSU. I'd try updating the BIOS. It's possible with a USB drive. Here are the instructions+BIOS file

    http://www.biostar.com.tw/app/en/manual/bios_update.pdf (SCROLL TO LAST PAGE)

    http://www.biostar.com.tw/app/en/mb/introduction.php?S_ID=580 (Click BIOS tab)
Ask a new question

Read More

New Build Systems