Sign in with
Sign up | Sign in
Your question

Monitor not displaying native resolution

Last response: in Graphics & Displays
Share
June 27, 2012 1:21:19 PM

Hello,

I've recently stumbled across this problem where my monitor refuses to display it's native resolution (1980x1200) booting goes fine till the Windows 7 logo, once Windows has loaded all I get is a black screen.

Decided to replace my 8800GT for a ATI x1950 to see if that would resolve the problem, uninstalled all nVidia related software and ran ccleaner.

Didn't solve the problem.

Started windows in VGA mode and lowered the resolution to 1440x900 no issues whatsoever.

What could the problem be ? 1980x1200 was never a problem in the past.

Specs:

ASUS P5N-E SLI running on the latest bios
Q6600
4GB DDR2 RAM
ATI x1950
550W PSU

Monitor: DGM MB24W
a b C Monitor
June 27, 2012 1:45:45 PM

Dumb question...

Have you installed the drivers for your display adapter?
June 27, 2012 2:04:24 PM

Yes, got the latest Catalyst drivers installed for this card.
Related resources
a b C Monitor
June 27, 2012 2:14:46 PM

What has changed since it was working properly?

Could you try system restore to a previous working state?
June 27, 2012 2:22:33 PM

Well nothing has changed, all I did was remove my old GPU and replace that. Uninstalled all drivers and installed ATI's correct drivers.

Okay I've tried to run on native resolution again and it works, tried a reboot and the issue seems to have been solved.

I have no idea why though. Weird stuff
!