Sign in with
Sign up | Sign in
Your question

Radeon 7770 Resolution Problem

Tags:
  • Radeon
  • Resolution
  • Graphics
Last response: in Graphics & Displays
Share
June 27, 2012 4:53:21 PM

So i received and installed the 7770 today. only problem I've run into so far is that the largest resolution I can set the card to (catalyst settings) is 1680x1050. My native resolution is 1920x1080, when I try and set my resolution back to 1920x1080(windows settings) I get a black space all around my screen.

Any solutions?

More about : radeon 7770 resolution problem

June 27, 2012 5:06:14 PM

if you are sure your monitor support 1920x1080, make sure your monitor fresh rate is 60HZ
try your monitor on other PC and adjust resolution to 1920X1080 to make sure its graphics card problem
m
0
l
June 27, 2012 5:38:44 PM

I just installed this graphics card, it was always set at 1920x1080 before I got the new card.
m
0
l
Related resources
June 27, 2012 5:49:17 PM

did you set refresh rate at 60HZ
did you uninstall your last drivers before you inserted your new gfx
it will be much easier if you can try 7770 on other PC to know what is the problem exactly
try the latest drivers
m
0
l
June 27, 2012 6:10:33 PM

Refresh rate is at 60HZ, I did uninstall the last drivers, and I do have the latest drivers for the current card and monitor.

I will try the monitor on another comp...
m
0
l
August 25, 2012 3:03:40 PM

I have the same issue any solutions?
m
0
l
January 26, 2013 4:59:06 AM

I had the same problem and I have just solved it. I'm a spanish user so maybe the translation for the buttons I pushed it's not so accurate, but hey, give it a try. In your AMD VISION Engine Control Center go to "My Digital Panels" (i guess) and then to "Scaling Option"... I dunno if that's the best translation. Anyway it should show you a percentage bar with the "Infraexploration" or "Overexploration" percentage you're using. Just set it back to 0% and that solves it!

Good Luck!
m
0
l
January 31, 2013 12:25:54 PM

Thanks so much cyberkash40!!! This resolved the problem, I found that after installing the AMD Vision Engine Control Center the default for the Scaling Option was almost 10% and not 0%. I have not idea why they did this and this setting over rides the Windows Screen Resolution settings.

Steps you provided were spot on!

1. Open 'AMD Vision Engine Control Center
2. Select -> 'Scaling Options' (Under 'My Digital Flat Panels' Tab)
3. Change 'Scaling Option' slider to 'Overscan' (0%)

This should scale out and allow you to utilize all of the screen real estate (1920x1080)
m
0
l
!