Sign in with
Sign up | Sign in
Your question

6970 xfire / eyefinity / dx9 WoW

Last response: in Graphics & Displays
Share
June 27, 2012 6:41:41 PM


Hi All,

New to this forum but been following Tom's hardware for quite sometime, good website & forum.

I have an "issue" I hope someone maybe able to help with...

I want to run WoW in dx9 in eyefinity utilising xfire is the conclusion, but the performance of WoW is totally shocking when running in fullscreen mode. Let me explain how I got to this conclusion -

DX11 - Window Mode
WoW does not offer Eyefinity in DX11, just the usual resolutions, however it will run DX11 in window mode and looks great on Eyefinity - BUT - windowed mode does not work with xfire and only one GPU is utilised.

DX11 - Full Screen
Just as a taster I ran WoW in normal resolution (ok looked very weird) but the performance was in fps and movement was stunning - just wanted I wanted - BUT - just look daft and wasn't usable

DX9 - Window Mode
OK, back to my single card 25 man raids poor fps etc. - NOT - using 2nd GPU but normal movement around cities etc is 50 - 60fps

DX9 - Full Screen
Utilising 2nd GPU (about 40% / 40%) but the FPS is awful - less than 20fps just normal movement, I assume this is something to DX9 mode? But why would DX9 Window Mode outperform Full Screen if anything it should be the other way round?

View / Comments?


System spec -
ASrock Extreme 6 mobo
8 gig ram
i7-2600 @ 3.40 (don't see a bottleneck)
2 x 6970 (HIS 880 & IceQ 900) - all monitors plugged into IceQ DVI, DVI, DP
Sammy MD230x3 monitor array
June 27, 2012 7:20:19 PM

faxfan said:
DX11 - Window Mode
WoW does not offer Eyefinity in DX11, just the usual resolutions, however it will run DX11 in window mode and looks great on Eyefinity - BUT - windowed mode does not work with xfire and only one GPU is utilised.

DX11 - Windowed (Fullscreen) is your best option. I run WoW on ultra preset with 8xAF 4xMSAA @4800x1200 (less than yours) on a single radeon 6970. The only time I see frames drop below 60 is during busy boss fights with lots of effects. Even then, it stays above 50. You have a more demanding resolution but I would think one card should handle your res with some slight reductions in settings.

Are you using the latest drivers and CAPs?
June 27, 2012 7:54:53 PM

All the latest drivers and CAP's, yes. Just annoying as I do get lag and would like the xfire to utilised
Related resources
June 27, 2012 8:06:31 PM

I guess the overring question is why is DX9 xfire performance so bad?
June 27, 2012 8:19:55 PM

Yeah, I don't know if progress has been made on getting eyefinity XFire working right with WoW. I haven't really kept up. In Lich King I was using a couple 5870 1gb cards in XFire at 4800x1200 maxed out with view distance manually-edited to maximum and it ran perfectly, nothing below 60fps. Whether both cards were actually working or whether only one was being used, I never cared to check with that game since performance was great.

But when the first cata patch was applied before the actual cata launch, things got very bad. Once I figured out that the tweaked game engine in cata was making me vram limited, I reduced texture resolution and AA and got awesome frames in some zones (with both cards strangely 100% utilized), and very weak frames (like 30-50) in other zones (regardless of v-sync off or on). It was like XFire was working in some zones and not working in others. At the time, they offered the "experimental" DX11 mode which improved things to about 50fps in most places, but only one card was being used.
June 27, 2012 8:23:16 PM

I've just disabled xfire and DX9 full screen mode is hitting 40 - 50fps (I'm sure disabling the catalystAI it will hit 50-60fps) with xfire sub 10fps...

It would certainly seem xfire & DX9 (throw in eyefinity for good measure) is an issue (aside from the fact blizzard should support eyefinity on DX11!!)

June 27, 2012 8:49:34 PM

Right!! Progress...

I actually loaded in the WoW AMD profile and it worked, well kinda of... Obviously I'm running the 64 bit client so had to rename the Wow-64.exe to Wow.exe but the upshot in that in 5924 x 1080 resolution I get 90fps+ movement, dropping relatively low in cities to 40 - 50fps, all on ultra. Both GPU's are being used.

Raid tomorrow night (or I may do a DS raid finder tonight just to have a nosey).

Does anyone know who to edit these application profiles (thinking for wow-64.exe and maybe tweaking)? RadeonPro?
a b Ý World of Warcraft
June 27, 2012 9:16:05 PM

Why would you use dx9 mode? DX11 gives such a big performance boost..
June 27, 2012 9:38:38 PM

not when you use eyefinity at 5974 x 1080. The fact that wow doesn't support eyefinity in full screen and therefore xfire isn't used...
June 27, 2012 9:46:48 PM

Sunius said:
Why would you use dx9 mode? DX11 gives such a big performance boost..


DX11 and Eyefinity don't work in WoW only DX9. Been an issue for a while but Blizzard is in no hurry to give support.
June 27, 2012 9:52:01 PM

Did a DS25 raid finder, getting 100fps+ on movement and a decent 50fps+ on boss fights - all settings on ultra @ 5974 x1080. I think my issue is solved.
August 16, 2012 1:33:05 PM

I pretty much have the same issue you had.

If possible, can you detail the exact steps you did to fix it? That would be fantastic.
August 16, 2012 3:26:33 PM

Basically
- setup the eyefinity group for 3 screens
- run wow in FULL screen (not window mode) in standard DX9
- one gotcha is that sometimes my cards don't go into crossfire mode (even though CCC & GPU-Z says they are) - you can tell by the lack of FPS in WOW. Just exit wow, disable / re-enable crossfire in ccc - restart wow
!