Sign in with
Sign up | Sign in
Your question

Screen larger than monitor

Last response: in Graphics & Displays
Share
June 28, 2012 1:04:30 PM

Hello, I just installed a new TV/Monitor, Philips 32PFL4017G/78 and specs say full HD. I am now using two monitors, this one and a LG that's fine with a 1680X1050 resolution. Windows states max resolution for the Philips is 1980X1080, but it does not look as good as the LG, and, worse, icons are half outside the screen. I installed drivers from my Zotac Nvidia GE Force 210 video card, and nothing changed.

Thanks,

Luis.

More about : screen larger monitor

June 28, 2012 3:32:34 PM

How come you use 2 different sizes' monitors?
a c 291 U Graphics card
a b C Monitor
June 28, 2012 4:07:11 PM

Use their respective resolutions, 1920x1080 for phillips and 1680x1050 for the LG. Don't try to force it display different resolution than it's native.
Related resources
June 28, 2012 4:14:41 PM

That's what I'm doing, the 1680X1050 is beautiful, but the 1920X1080 seems strange, and Windows 7 screen is larger than the monitor's.

Thanks, Luis.
a c 291 U Graphics card
a b C Monitor
June 28, 2012 4:46:22 PM

What cable are you using to connect the Phillips? If I were you, I'd try disconnecting LG, starting the PC with Phillips connected and try making it work alone.
June 28, 2012 5:02:32 PM

Philips is HDMI, LG is DVI, I tried to work with only Philips connected, and it was the same.

Thanks, Luis.
June 28, 2012 5:05:34 PM

A lot of modern televisions will apply a 5% or so overscan to the image, basically zooming in on the picture, resulting in a non 1 to 1 pixel mapping. This is often unnoticeable when the tv is connected to a blu-ray player or gaming console, but will result in part of the screen being cut off and poor image quality when connected to a PC. This is from Phillips FAQ regarding connecting the display to a PC:

"For a 1080i/1080p video signal, if you want to view the entire picture with 1:1 pixel mapping (i.e. 1080p picture on a 1080p screen, if your TV is 1080p) without the 5% overscan which crops the picture on all four sides, please select Unscaled picture format for best performance."

Source: http://www.p4c.philips.com/cgi-bin/dcbint/cpindex.pl?sc...

Page 16 of the manual for the TV provides some more detail under the Change Picture Format heading:

"[Unscaled]: Provide maximum detail for PC. Only available when PC mode is selected in the Picture menu."

Manual: http://download.p4c.philips.com/files/3/32pfl4017g_78/3...
a c 291 U Graphics card
a b C Monitor
June 28, 2012 5:05:57 PM

What was the resolution set to when you were working with Philips only?
June 28, 2012 5:09:12 PM

Hey, my icons returned to the screen, thanks a lot, but screen is still strange, not as beautiful as the monitor.

Thanks again, Luis.
June 28, 2012 5:15:48 PM

I did not change the resolution, it is set 1920X1080, but now my icons returned to the screen, and I adjusted it's brightness and sharpness, and it is getting more like the LG monitor. Can this be a driver issue? My drivers are up to date, I downloaded instead of using the supplied CD.

Thanks, Luis.

June 28, 2012 5:16:15 PM

Most TVs also offer a lot of options to make the picture look "better." Often times, many of these options are adjusted by default to make the picture look bright/vibrant when viewing movies or games but often unnatural and provide poor image quality when the display is connected to a PC. You may want to play with some of the picture options. Try changing the sharpness and disabling things such as Noise Reduction, Color Enhancements, and Dynamic Contrast (See page 28 of the above linked manual). Note, some of these options may be disabled while the display is in PC mode.
June 28, 2012 6:59:36 PM

Dear friends, I found the issue, PC mode was OFF. Thank you very much for all your time and patience.
Very best regards,
Luis.
June 28, 2012 7:19:32 PM

You are welcome! Glad you got the issue resolved!
June 28, 2012 8:13:45 PM

Manual did not have a hint about this setting. Thanks again and have a nice Friday.
!