Sign in with
Sign up | Sign in
Your question

Image stretching

Last response: in Graphics & Displays
Share
June 29, 2012 1:52:08 PM

Hello! I'm having a little problem. I've no idea how to turn off image streching in games on VGA screen. I know it can be done on hdmi. It's like, for example, i play counter strike 1.6 on 640x480 resolution and the pc just forces it to completely fill up the screen (it does so in any other resolution too), so there are no black bars at the sides, that way it looks just horrible and the horizontal sensitivity is really strange. Does anybody knows how to disable that on a VGA screen?

More about : image stretching

June 29, 2012 2:02:26 PM

There are a few ways to do this:
1) Play in windowed mode
2) get a monitor or TV that has the ability to change the input source aspect ratio. By default all TVs and monitors want to stretch an image to fill the full screen, which makes distortions, or display native resolution, which tends to be very small. Most mid to high end TVs have letterboxing options, and a few high end monitors will have this feature, but either way you will suffer a little input lag.
3) play at native resolution, or at least a low resolution that shares the same aspect ratio as the screen you are playing on. This chart can be helpful in picking a good resolution: http://en.wikipedia.org/wiki/File:Vector_Video_Standard...
June 29, 2012 2:06:49 PM

oh, forgot to mention: a lot of older games (not sure if CS is one of them) will have hacks or registry edits available to allow for widescreen game play. Every once in a great while I like to play an older game that is stuck at 4:3 aspect ratio, and I either have to find a hack, or else just get use to the stretch as I am not willing to pour money into a better monitor/TV, and windowed mode breaks the immersion for me.
Related resources
June 29, 2012 2:12:46 PM

What video card you have.?
I use Image scaling (GPU scaling) option found in video card control panel to make games appear right.
I play old age of empires 2 and it works fine

Also if you want 640x480 you can right click on games exe file go properties and under compatibility check
*run in 640x480 screen resolution
July 1, 2012 4:31:24 PM

Sorry about this late reply, but I have HD 5670 512mb gpu.
If I run it under compability it still is stretched out.
And if I play it in windowed mode everything is so small, that i cant see a thing
July 1, 2012 6:56:42 PM

try the GPU scaling option mentioned by duxducis, that may be your best bet.
Otherwise you will have to hook into a TV/monitor that simply shares the aspect ratio that you are looking for, or has letterboxing features (often labeled as 'zoom' on most TVs), or look for hacks that will let you play at your screens native resolution.
!