Sign in with
Sign up | Sign in
Your question

New cpu blank screen

Last response: in CPUs
Share
January 2, 2013 8:22:55 PM

I have a ASRock N68C-GS FX mother board and i updated the bios and pulled the battery out for 5 minutes and installed my new AMD fx-6300. I powered it up and everything sounds great but nothing registers on the screen and the keyboard and mouse wont light up.

More about : cpu blank screen

January 2, 2013 8:35:25 PM

could be a bad motherboard. recent comments on newegg are bad

Pros: supposedly AM3+ upgradeable

Cons: VGA D connector only. Lame integrated video. Poor BIOS detection. No boot screen or memory count that I could find.

Other Thoughts: I have built over 1000 PCs, starting as far back as 1979. I haven't had this much trouble with a board since the mid-90s. I bought it to replace a superior board that failed. Detected 800mhz RAM as 533mhz. Sure, its tweakable, but who would want to tweak this board?

Pros: Motherboard worked fine. parts seemed good.

Cons: USB ports on back dead on arrival. I enabled usb in bios with no sucess. RMAd today

Pros: None. I would say price, but it blew up everything hooked to it within days.

Cons: Destroyed everything hooked to it in a matter of days.
January 2, 2013 8:50:50 PM

http://www.asrock.com/MB/download.asp?Model=N68C-GS%20U...

Your board won't run piledriver cpus; it's too old. I recommend this board:
http://www.newegg.com/Product/Product.aspx?Item=N82E168... (bios file p1.20 required; may require a bios flash before cpu posts) http://www.asrock.com/mb/AMD/960GMU3S3%20FX/?cat=CPU

You may have this issue with any number of micro atx boards with older chipsets; the atx boards with 970 and 990 chipsets are more likely to work out of the box, but your case may not work with atx boards. All cost a little more.


Related resources
January 2, 2013 10:24:26 PM

I double checked your link. No piledriver 6300 cpus listed, only older phenom II denab. Am3+ can cover a wide group of cpus, but the piledriver is one of the latest. You can try to email asrock tech support and see if they will mail you a new bios file for your older motherboard. ECS did this twice for me, but it takes time. I would order the new board and sell your old one on craigslist or anandtech. But again, you may still need to flash the bios for your new board to work. Places like newegg might have newer inventories with the latest bios file flashed at the factory; otherwise, you may need a low end sempron 140 to flash before your new piledriver will post. Good luck.
January 2, 2013 11:19:04 PM

there is
AM3+ FX FD6300WMW6KHK 95W Piledriver 3500MHz 2000MHz 2MBx3 8MB C0 P1.30

can you put in the old processor to see if it still work?
January 2, 2013 11:29:30 PM

Now I see it; too many posts today; need to get away from this screen for awhile. The last poster is correct; try flashing with your old cpu then try the new 6100 again.
January 3, 2013 12:02:04 AM

thanks for all the support it does help I tried the old processor and it works fine!Im stumped.wait do i have to use ddr3 ram cus im still using ddr2.i know it supports ddr3 but does it require it?
May 12, 2013 2:21:18 PM

13kempmyl said:
thanks for all the support it does help I tried the old processor and it works fine!Im stumped.wait do i have to use ddr3 ram cus im still using ddr2.i know it supports ddr3 but does it require it?


Obviously this thread still isn't active, but I have the exact same problem with the same motherboard and processor. I have been searching for weeks and this is the only related thread. I was wondering if you solved this and if so how did you do it? I have just ordered new ddr3 ram, hopefully that will fix it.
October 18, 2013 1:13:21 PM

The amd 6300 vorks only vith ddr3 ram read the motherboard manual.
!