Sign in with
Sign up | Sign in
Your question

Cant get my nvidea geforce 610m 2GB working help ple

Last response: in Graphics & Displays
Share
June 29, 2012 11:55:17 PM

when i try and install latest graphics drivers for my nvidea geforce 610m 2GB on my ASUS X53SD-SX189V
15.6" LAPTOP,the drivers wont install and it says cant find the hardware for this drivers ,also when i look in device manager,it says device can not start but when i update drivers in the driver tab in vga adapter properties,it says the latest drivers are installed? the card isnt running as far as i can see on my second screen when running blacklight retrabution use GPU-Z,its running the graphics of the intel HD graphics 3000 can anybody help me get this working many thanks dan
a c 103 U Graphics card
June 30, 2012 12:09:27 AM

i think the problem is that your laptop has turned off the dedicated graphics and is only running the intel graphics on the cpu....something to try is to check in the bios of the laptop and see if there is a default graphics setting or something and make sure that it is set to the dedicated card not the intel.....that way when the laptop boots into windows it is using the 610 which will then allow you to install the drivers for it...once you do that you can switch that setting back in the bios but you gotta have some software that turns the gpu on when its in 3d i imagine nvidia control panel will do that
June 30, 2012 7:54:18 PM

drums101 said:
i think the problem is that your laptop has turned off the dedicated graphics and is only running the intel graphics on the cpu....something to try is to check in the bios of the laptop and see if there is a default graphics setting or something and make sure that it is set to the dedicated card not the intel.....that way when the laptop boots into windows it is using the 610 which will then allow you to install the drivers for it...once you do that you can switch that setting back in the bios but you gotta have some software that turns the gpu on when its in 3d i imagine nvidia control panel will do that



Thanks For The Help, Im Looking At My Bios And There's No Graphic Option On It What So Ever. All It Says In The Advance Section Is: Post Logo Type, Start Easy Flash, Play Post Sound, Speaker Volume, Internal Pointing Device, Wade On Lid Open, Intel Virtualization, Intel AES-NI, Lagacy USB Support, SATA Configuration. Then In The Other Sections Its Just Boot, Security And Save & Exit. I Had Already Looked In The Bios For This Option But Had No Luck, Any Other Suggestions ?
Related resources
a c 103 U Graphics card
June 30, 2012 10:58:58 PM

there has to be some kind of setting that allows you to enable the dedicated card...check the intel display properties and look to see if there is something in there
July 1, 2012 12:43:59 AM

i went to the asus.com and looked up the laptop , and thay have nvidea drivers ther that work,and every thing is fine now thanks for help
a c 103 U Graphics card
July 1, 2012 12:58:39 AM

thats really odd...you could get the asus drivers to work but not nvidia's...well i am glad it all worked though
!