Sign in with
Sign up | Sign in
Your question

Windows Explorer Sort by filename sorts wrong

Last response: in Windows XP
Share
Anonymous
June 15, 2005 7:36:05 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Is there an option I'm missing which would fix the following ?

I display a bunch of files in Win Explorer.
Click on the NAME heading to sort by name.

It sorts file names ignoring leading zeros.

Here's a sample list of filenames after the sort:

00005042.IDX
00008487.DAT
00008487.IDX
8859-1.cod
8859-15.cod
8859-1w.cod
00009830.DAT
00009830.IDX
00009833.DAT

TIA, QE in NJ
Anonymous
June 15, 2005 1:19:46 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Use TweakUI

TweakUI
[+] Explorer
? Use intuitive filename sorting

[[If this is checked the Explorer will sort files so that, for e.g. “File 5”
comes before “File 10” because 5 comes before 10. If this is unchecked then
Explorer will use literal sorting, in which case “File 10” will come before
“File 5” because 1 comes before 5. ]]
----

Download TweakUI here >>>

Microsoft PowerToys for Windows XP
http://www.microsoft.com/windowsxp/pro/downloads/powert...

Tweak UI
TweakUI.exe
-----

Tweak UI for Windows XP Guide
http://www.winxpsolution.com/Tweakuixppro.aspx

-----

The Sort Order for Files and Folders Whose Names Contain Numerals Is
Different in Windows XP Than It Is in Windows 2000
http://support.microsoft.com/default.aspx?scid=kb;en-us;319827

Windows Explorer Incorrectly Sorts Files and Folders with 10 or
More Consecutive Numerals
http://support.microsoft.com/default.aspx?scid=kb;en-us;318872

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:ks7va1thq399b2f2lqei0dh2rp9qdc9mvb@4ax.com,
QuienEs <QuienEsREMOVETHIS@ANDTHISatt.net> hunted and pecked:
> Is there an option I'm missing which would fix the following ?
>
> I display a bunch of files in Win Explorer.
> Click on the NAME heading to sort by name.
>
> It sorts file names ignoring leading zeros.
>
> Here's a sample list of filenames after the sort:
>
> 00005042.IDX
> 00008487.DAT
> 00008487.IDX
> 8859-1.cod
> 8859-15.cod
> 8859-1w.cod
> 00009830.DAT
> 00009830.IDX
> 00009833.DAT
>
> TIA, QE in NJ
Anonymous
June 15, 2005 2:20:39 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

The Sort Order for Files and Folders Whose Names Contain Numerals Is
Different in Windows XP Than It Is in Windows 2000:
http://support.microsoft.com/default.aspx?kbid=319827

--
Ramesh, MS-MVP
Windows Shell/User

Windows XP Troubleshooting
http://www.winhelponline.com

Windows XP Newsgroup Setup Instructions for Outlook Express:
http://www.microsoft.com/windowsxp/expertzone/newsgroup...

"QuienEs" <QuienEsREMOVETHIS@ANDTHISatt.net> wrote in message
news:ks7va1thq399b2f2lqei0dh2rp9qdc9mvb@4ax.com...
> Is there an option I'm missing which would fix the following ?
>
> I display a bunch of files in Win Explorer.
> Click on the NAME heading to sort by name.
>
> It sorts file names ignoring leading zeros.
>
> Here's a sample list of filenames after the sort:
>
> 00005042.IDX
> 00008487.DAT
> 00008487.IDX
> 8859-1.cod
> 8859-15.cod
> 8859-1w.cod
> 00009830.DAT
> 00009830.IDX
> 00009833.DAT
>
> TIA, QE in NJ
>
>
Related resources
Anonymous
June 15, 2005 11:48:26 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Thanks Ramesh and Wesley.

If anyone wants to change it to the way I wanted it to work w/o lots
of reading, just create a text file with the following contents,
named "anyname.reg"


======================================================
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoStrCmpLogical"=dword:00000001
======================================================

Find the file in explorer, right-click and select MERGE.

Then reboot.

Works like a charm.

Cheers, QE in NJ
]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]
On Wed, 15 Jun 2005 03:36:05 GMT, QuienEs
<QuienEsREMOVETHIS@ANDTHISatt.net> wrote:

|Is there an option I'm missing which would fix the following ?
|
|I display a bunch of files in Win Explorer.
|Click on the NAME heading to sort by name.
|
|It sorts file names ignoring leading zeros.
|
|Here's a sample list of filenames after the sort:
|
| 00005042.IDX
| 00008487.DAT
| 00008487.IDX
| 8859-1.cod
| 8859-15.cod
| 8859-1w.cod
| 00009830.DAT
| 00009830.IDX
| 00009833.DAT
|
|TIA, QE in NJ
|
Anonymous
June 16, 2005 1:31:45 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

You're welcome QuienEs.

--
Ramesh, MS-MVP
Windows Shell/User

Windows XP Troubleshooting
http://www.winhelponline.com

Windows XP Newsgroup Setup Instructions for Outlook Express:
http://www.microsoft.com/windowsxp/expertzone/newsgroup...

"QuienEs" <QuienEsREMOVETHIS@ANDTHISatt.net> wrote in message
news:v211b1d72shj3e85a0325jktv8c25ca1b2@4ax.com...
> Thanks Ramesh and Wesley.
>
> If anyone wants to change it to the way I wanted it to work w/o lots
> of reading, just create a text file with the following contents,
> named "anyname.reg"
>
>
> ======================================================
> [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
> "NoStrCmpLogical"=dword:00000001
> ======================================================
>
> Find the file in explorer, right-click and select MERGE.
>
> Then reboot.
>
> Works like a charm.
>
> Cheers, QE in NJ
> ]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]
> On Wed, 15 Jun 2005 03:36:05 GMT, QuienEs
> <QuienEsREMOVETHIS@ANDTHISatt.net> wrote:
>
> |Is there an option I'm missing which would fix the following ?
> |
> |I display a bunch of files in Win Explorer.
> |Click on the NAME heading to sort by name.
> |
> |It sorts file names ignoring leading zeros.
> |
> |Here's a sample list of filenames after the sort:
> |
> | 00005042.IDX
> | 00008487.DAT
> | 00008487.IDX
> | 8859-1.cod
> | 8859-15.cod
> | 8859-1w.cod
> | 00009830.DAT
> | 00009830.IDX
> | 00009833.DAT
> |
> |TIA, QE in NJ
> |
>
January 23, 2013 9:51:30 PM

Thanks for the notes which helped me.

Actually I found I had to add a line of "REGEDIT4" on top in the anyname.reg to make it possible to merge on my Windows XP SP3.
===========
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoStrCmpLogical"=dword:00000001
===========
!