Sign in with
Sign up | Sign in
Your question

3770K doesn't even POST

Tags:
Last response: in CPUs
Share
January 3, 2013 11:36:53 AM

Hello,
i just got this cpu and can't get it to work.
Basically it doesn't even POST and the monitr says there is no signil from the coputer... but should't this cpu have an integrated graphic system?
What am i missing?
Thank you

More about : 3770k post

January 3, 2013 11:49:16 AM

Please list your computer specs, especially your motherboard. Just as a guess, you may not have a z77 board and if not you might need to update your bios to support your cpu.
January 3, 2013 11:51:59 AM

It is a Z77 motherboard.. from Asrock
Related resources
a c 94 à CPUs
January 3, 2013 12:00:43 PM

is the bios updated to use the processor?
January 3, 2013 12:04:52 PM

how do i know that?... i guess it is since it's a z77
additinal infos: the keyboard nor the mouse light up
January 3, 2013 1:10:37 PM

Ok thanks guys this is solved.
I had to connect the 12V conncetor which i didn't before because my power supply doesn't have the 8 pin connector but i used the 4 pin and it worked.
!