Sign in with
Sign up | Sign in
Your question

4.3 gig formated as 2.1 ?

Last response: in Storage
Share
September 3, 2001 4:19:18 PM

I have an old 4.3 gig Fujitsu HD I want to use to play with Linux. It is a 4.3 (maked on drive and I remember it was 4.3 way back when I was using it). Now, I can only format it as 2.1. I have tried cleaning it with the program from Fujitsu, wiping out the MBR, and tried manually setting the drive info in the BIOS. What could have happened to the other 2+ gig ? If there was a hidden partion, would I be able to see it with partion majic ? Any help would be greatly appreciated !

The sum of the intelligence on the planet is a constant; the population is growing.

More about : gig formated

September 3, 2001 6:51:49 PM

What Operating System are you using? Is the BIOS seeing the full capacity?

<font color=red><b>"Can you deal with that!"</b></font color=red>
September 3, 2001 8:19:35 PM

Win98/Linux 8.0. Could it be the ribbon cable ? The bios sees only 2.1 LBA. When I format on another PC (win98) 4.3 gig. I also have a 30 gig in my PC (Diff cable)


The sum of the intelligence on the planet is a constant; the population is growing.
Related resources
September 4, 2001 3:28:54 AM

<font color=red>So if the BIOS is seeing 2.1Gig then it's the BIOS configuration. If it works and see's the full capacity of the drive on another system then it's not the drive either.</font color=red>

<font color=blue>Has this system ever seen anything over 2.1Gig? It could be a BIOS limitation. Other then that if the BIOS is set to 'Auto' detect the hard drive it should see the full capacity ... If not set it to 'User' and see if the CHS settings are located on the top of the drive itself?</font color=blue>

<font color=green>Hope that helps!?! Keep us posted ...</font color=green>

<font color=red><b>"Can you deal with that!"</b></font color=red>
Anonymous
a b G Storage
September 4, 2001 3:32:36 AM

Right there tells me either your CMOS configuration is wrong or corrupt, or you have a controller failure. The diagnostic screen (POST) should show the drive's params if its enabled on the CMOS. The only other thing would be if you had another drive connected on the same channel and they were not compatible with each other. I've seen CDROM's do that to some hard drives..

Linux should not at all have any trouble seeing a full drive capacity like that. I only ever ran into trouble with older linux and a 10 gig drive, but all the new ones can see much much more.

Also when doing the setup in Linux, run FDISK or CFDISK, and delete any existing partitions that might show up there...
September 10, 2001 6:19:34 AM

Make sure BIOS reads the drive at full size. Then REPARTITION your drive to make the partition full sized.

Back to you Tom...
September 12, 2001 1:37:12 PM

Thanks for all your responces,

I could not get the BIOS of my PC to see the drive as 4.3 LBA. I could not make it not use LBA.(BTW using ASUSA7V133 with latest BIOS), but my kids pc's BIOS would see it as 4.3 as it would let me NOT use LBA (still 2.1 with LBA). They have a Aopen AX6BC. I formated and pationed the $hit out of it and finaly gave up. They are happy as they get another 4.3 gig drive, and I have a new Maxtor 20 gig for may Linux. Sometimes you just have to givin and move on (and spend money !!)
Thanks again for all your help. Know all I have to do is get my F#cking second NIC working under Linux so I can share the internet and the family will leave me alone to learn Linux !!!

The sum of the intelligence on the planet is a constant; the population is growing.
September 16, 2001 3:33:11 AM

Isn't 2.1 GB the limit of FAT? Did you format it as FAT? If so, then make sure it's formatted FAT32... (or ext2 for linux).

Lyrics. Wasted time between solos.
September 16, 2001 10:31:23 PM

I would format on another PC as 4.3 gig fat32. When I put in back in my pc it would read it as 2.1 gig. Still in the other being used as 4.3... :o )

-N-

The sum of the intelligence on the planet is a constant; the population is growing.
!