Sign in with
Sign up | Sign in
Your question

Trying to install Sapphire Radeon 6850 Problem.

Last response: in Graphics & Displays
Share
July 1, 2012 9:44:13 PM

I have a problem with my brand new Sapphire radeon hd 6850 1GB.

just brought this card a few days ago from amazon and tried to install it into my system but not working as i aspect it to be.

ive uninstall my old drivers and used driver sweeper and reboot and tried to install the latest drivers from amd but everything was installed except for the display driver.
been trying to install all the amd drivers from the amd site still fail

but some of them did install without fail and as soon as i reboot it comes up with "no ATI drivers install or the driver does not support my hardware" :S

and some didnt come up with that error but the catalyst center wont run..

right now im using my old hd 4850 with driver 10.7 and no problems at all

another problem is when i had my new 6850 card in and go into my device manager it doesnt show my new card name and only display it as "standard VGA graphics adapter" is that normal? is it not detecting my new GPU?

my specs:

windows 7 32-bit
cpu : AMD phenom II X4 965 3.4GHZ
mobo : Gigabyte AM3 MA78LMT-US2H
ram : 4GB DDR3 corsair 2000MHZ
gpu : xfx radeon HD 4850 512mb
psu : 500w OCZ

any help would be much appreciated, thank you.
Anonymous
a c 117 U Graphics card
July 1, 2012 9:50:26 PM

if the 4850 is working fine with the drivers and the 6850 isn't along with not being recognized in windows: do you also smell an RMA process or is it just me?

though try it one more time and make sure it is seated properly and the power connectors attached.
July 1, 2012 10:00:26 PM

ive been messing around with drivers all weekend and yea i guess RMA and instead of replacement i could get a nvidia card... ill give it one more try and maybe try it on a friends system

thanks anyway
July 2, 2012 4:48:33 PM

thats its cant get it to work, i've placed in properly and checked the power connectors.. now its RMA time

this is my last time i'm going with AMD gpu.. too many driver issues
!