Sign in with
Sign up | Sign in
Your question

Memory stick not working in usb

Last response: in Windows 7
Share
February 7, 2012 4:39:31 PM

Hello,
I have three memory sticks non now work when entered into usb. Have tried webcam and mouse in same usb they each load correctly.
When I enter memory stick I hear an audio ping but no loading follows. I have tried checking if driver is up to date etc and all shows correct

More about : memory stick working usb

a b \ Driver
a b $ Windows 7
February 7, 2012 4:48:40 PM

Hi :) 

Try the sticks in ANOTHER machine..if they dont work...bin them...

All the best Brett :) 
m
0
l
February 7, 2012 4:52:52 PM

all stick work correctly in another machine
m
0
l
Related resources
a b $ Windows 7
February 7, 2012 4:56:50 PM


If they don't show up at all in explorer, they could be faulty.
The fact that they do not load by default when plugged in has to do with Autoplay. If that is disabled, they will not load/launch automatically upon insertion, but you can still access the content via Explorer (see above).
m
0
l
February 7, 2012 5:10:09 PM

I am on windows 7 medeion aroya computer.
i have loocked at auto play and box was ticked so assumed its enabled.
At one stage did get a search for driver wen stick was entered but driver not found. Followed this up by checking via prompts to confirm that driver was infact up to date.
m
0
l
February 7, 2012 5:15:25 PM

memory stick shows up in 'printers and devices' but it has a yellow marker with exclamation mark. The same symbols are on an additional medion hard drive addition.
m
0
l
February 7, 2012 5:20:29 PM

I'd check for an update to your onboard USB drivers in case there's some corruption.
m
0
l
February 7, 2012 5:21:06 PM

Also, are you using a USB hub? It could be a power issue.
m
0
l
February 7, 2012 5:38:16 PM

have followed prompts for updating and checking drivers, all mentioned up to date.
can you expand the details regarding USB hub - I dont seem to have had that listed in all of my prompts using computers help
m
0
l
February 7, 2012 5:45:16 PM

a USB hub is an expansion you plug into your computer's USB that allows you to connect more USB devices to that one port. If you aren't connecting the device directly into the computer tower, you are likely using a USB hub.
Please do the following for me:
Go to start menu > Control Panel > Devices and printers then right click on the Memory stick and go to properties. Then click the hardware tab and click properties there. Where it says Device Status, please copy and paste what it says there.
m
0
l
February 7, 2012 5:47:19 PM

additional info on my problem
Its as though my computer has the drives but the memory stick cant find them (applicable for the memory sticks only) - they just dont self load nor do they apear in the 'computer' section where I used to find them when pluged into a usb - a double click on it would open it - not anymore though, hence my need for help (out in sticks so this is the only way I can look for help)
m
0
l
February 7, 2012 5:58:29 PM

A bit slow sory, I aint a yougster,,,,
I did what you directed but couldn figure on how to cut and paste since no tool bar at top.
It gave listing
USB Flash Drive
Model USB Flash Drive
Catagories shared device
otherwise others un available
m
0
l
February 7, 2012 6:00:45 PM

copy it using CTRL + C then paste it to the reply here using CTRL + V
m
0
l
February 7, 2012 6:00:52 PM

ref usb hub.
I am only using single port there are several on this computer so use the two on front for my memory sticks. Checked these by taking mouse out of back one and entering in front, it loaded front ok as did the webcam in the other front
m
0
l
February 7, 2012 6:12:59 PM

Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)
m
0
l
February 7, 2012 6:14:02 PM

I had trouble cutting and pasting, it wouldnt highlight anything much but for the above which I figured perhaps was what you needed,,,
m
0
l
February 7, 2012 6:34:27 PM

Ok there's something screwy with your drivers. Let's try this:
Go to start menu > Control Panel > Hardware and Sound > Device Manager.
If it's not already expanded, meaning showing the items listed under it, click the arrow next to "Disk drives" and see if it lists a Memory USB Device or something similar. Right click the Memory USB Device, or whatever your memory stick is called, and click "Update driver Software" then click Search Automatically for updated driver software. If that finds something then good, problem might be fixed, if it says "The best driver software for your device is already installed," close that window and right click the drive again and click uninstall then press OK. Then at the top of the window you'll see an icon that looks like a computer with a magnifying glass on it, if you hover over it it will say "Scan for hardware changes" click that and it'll reinstall the drivers. If this doesn't solve your issue, tell me the exact model of USB drive and i'll see if i can help more.

I also recommend downloading a program called Malware Bytes. Just google it. Download it and run the program using a full scan. It's possible you have a virus or malware causing an issue. You did say the drives all work on a different computer correct? Also, try another USB slot on the same PC. Perhaps the one in the back that you have the mouse plugged into.
m
0
l
February 7, 2012 6:48:17 PM

I am working on above but may have delays - its complicated.
Where do I get model of usb drive
m
0
l
February 7, 2012 6:50:39 PM

it will be on the USB drive it'self usually. Just the model name and any numbers etc you see on it should suffice. And the drive size ^^
m
0
l
February 7, 2012 6:52:29 PM

The broadband provider provides a security wall etc and I have run it and nothing found.
Have already tried memory sticks in back ports same result.
will continue following above advisory before I try the malware
By the way thanks so far
thank to you others outhere also
m
0
l
February 7, 2012 7:00:28 PM

Disk drive shows
Hitachi HCS5C1010CLA382SATA DISK DEVICE
Updated showing best etc
Is it this item I should un-install. its the only one shown when disk drive is expanded
m
0
l
February 7, 2012 7:05:35 PM

no that's not it. Don't touch that one!
m
0
l
February 7, 2012 7:07:46 PM

The memory sticks are 'Kingston data traveler'
'Lexar'
and 'Medion'
I also tried a PROlectrix dongle which always self loads and installs its driver when entered into a USB port for the first time, not now though - ..
m
0
l
February 7, 2012 7:09:29 PM

Remotely solving your particular issue is very difficult considering your level of tech knowledge. To attempt to update the drivers, go to Devices and Printers again, right click the memory stick drive, go to the hardware tab then properties. Then go to the driver tab and click Update Driver.
m
0
l
February 7, 2012 7:13:03 PM

There is only one entry Hitachi as given -
There is under 'universal serial bus controllers' USB Mas storage device listed - this seems to be the memory sticks I have tried into usb port. I will deleat these listings and see what this gives
m
0
l
February 7, 2012 7:14:43 PM

yes USB Mass Storage Device would be the memory stick.
m
0
l
February 7, 2012 7:20:03 PM

It wont let me update driver this is grey non accesable
m
0
l
February 7, 2012 7:31:01 PM

have completed scan for hw changes, havent found any feedback from this can which is now complete.
Un installed the usb mass storage devices shown and the came back when I re tried the memory sticks. By the way they have the yellow marker on them and I have checked driver update
m
0
l
February 7, 2012 7:44:48 PM

Have checked the driver details for stick
C:\WINDOWS\SYSTEM32\DRIVERS\USBFILTER.SYS
C:\ ETC \USBSTOR,SYS

Dont know if this is valid but my computer is running on 64 I think..
m
0
l
February 7, 2012 7:47:39 PM

ok well then lets do this for one of them, whichever is the smallest or has the least data. I want you to take it to another computer and back up the files to that computer then format the memory stick. Format it using Fat32 not NTFS just to make sure. Then bring the drive back to the PC you're using and see if it works. If it doesn't work then I'll have to come back and help you later cause my time here has run out. Make sure you copy the files back to the drive afterward in any case.
m
0
l
February 7, 2012 7:48:43 PM

before I quit for the night - can anyone tell me in an easy way, how I mark this web page forum so that I can find it tomorrow, the only way I know is to use google memory but ime sure thers an exact way - aint there ?
m
0
l
February 7, 2012 7:50:28 PM

Ref re formating etc as above, I have a new un used stick that I can use anytime, this may be the best way forward do you think
m
0
l
February 7, 2012 7:59:47 PM

new stick didnt work either
m
0
l
a b $ Windows 7
February 7, 2012 8:03:19 PM

AH. did you say that you got a message along the lines of

driver not signed?

try this

try this.

run gpedit.msc

click user configuration
then administrative templates
then system
then driver installation
then ‘code signing for device drivers’

then rest is self explanitory.



then go into device manager


click start and search for device manager (or go into control panel and search)


right click on the memory stick and uninstall. then reboot.


when you next plug usb in it should start to install the drivers


m
0
l
February 7, 2012 8:03:31 PM

There's some stupid driver issue and it's going to be a B**ch to fix remotely. You want to bookmark the page, it's different in each browser. Internet Explorer has Favorites. just add to favorites.
m
0
l
February 7, 2012 8:21:44 PM

Ref shankys advisory, ,yes I have followed this system but sadly it didnt change when I turned computer back on and entered the memory stick
m
0
l
February 7, 2012 8:42:22 PM

Thanks folks
will try again tomorrow
m
0
l
February 8, 2012 7:04:17 AM

The fault still persists. The opinion of my helpers seems to be toward it being a driver problem. This seems to be confirmed by the fact that when I uninstalled the memory stick icons from the listing in device manager, re booted then entered a memory stick in the usb port, the icon returned to the device manager but with a yellow triangle marker on it.
THE YELLOW TRIANGLE WITH EXCLAMATION MARK COMES UP IN DEVICES AND PRINTERS ON EACH AND EVERY MASS STORAGE DEVICE I TRY IN ANY USB PORT AND ALSO FOR THE HD DRIVE2GO EXPANSION WHICH HAS AS SPECIAL FITTING ARRANGEMENT AT THE TOP OF THIS MEDION COMPUTER ON WINDOWS 7 64 BIT
Any helpers out there please ?

Another point to mention - with the memory sticks in the ports, when I switched on my computer, they used to light up and wink , seemingly as they where identified or found by the computer, since this fault they havent winked or lit up

When re starting computer a message is received
installing device driver
then
device driver was not sucessfuly installed

If it is a driver problem then should I download drivers from internet ? I looked at this but came unstuck when I discovered the costs - free downloads didnt come free it would seem. Any seperate guidence on possible download solution ?
m
0
l
February 8, 2012 6:33:53 PM

Fuyukazehime said:
There's some stupid driver issue and it's going to be a B**ch to fix remotely. You want to bookmark the page, it's different in each browser. Internet Explorer has Favorites. just add to favorites.




Did you have any further thaughts on my problem ??
Please read my latest entry which covers the driver error flaging.
I have made no further progress
m
0
l
February 9, 2012 2:25:16 PM

Anyone -- can you throw light on this problem please....
m
0
l
February 10, 2012 3:34:32 PM

Update on my problem

If I disable driver signature enforcement when I boot, I am able to enter each and every memory stick in each usb port.

Is there a way to correct this problem within the computer rather than via a download modification
m
0
l
February 22, 2012 5:56:43 PM

There must be a way, is there anyone out there who knows how to solve this little mystery ????
m
0
l
November 25, 2012 2:08:21 PM

stonepicker said:
There must be a way, is there anyone out there who knows how to solve this little mystery ????

Did you ever solve this because I am having the same problem with USB drives as well as with USB hubs (powered or unpowered with nothing plugged into them - just don't install)

What confuses me most is that I have Win XP and Win 7 dual bootable and the problem exists in both operating systems. Does that make it a BIOS issue or Hardware?
m
0
l
November 25, 2012 4:36:29 PM

YES - I simply kept it simple. I entered the disk that came with the computer and the system returned to its correct state.
I think the error came about after downloading a music xchange facility called BearShare or something similar.
I thaught I had got rid of this download but perhaps remnants had embeded in the computer and interfered with the system.
KIS - Keep It Simple and you may find the answere.. all of the complex stuff kept my head in a spin and no one suggested something simple like surring the CD that came with the computer....
ps: sory with delay in repply, I havent been back on this forum since the problem encountered and couldnt remember password etc
m
0
l
January 25, 2013 12:16:30 PM

Hi,

I'm jumping into the thread here but I have a similar problem. I have a memory stick which has stopped working. First, it would show a dialog box offering to 'scan and fix' every time I inserted it, but still functioned. Then it stopped showing up in My Computer, but Device Manager displayed it as a 'Base System Device' with a yellow exclamation mark. Tried disabling, enabling, uninstalling and reinstalling driver, and no luck.

Now I've just plugged it in, trying different usb ports on different PCs and it won't even show up in Device Manager. The light on the stick lights up, but that's it.

Is there anything I can do?
m
0
l
January 25, 2013 5:55:52 PM

1. Try pressing F8 upon switching your computer on, select disable signature enforcement (something like that is avail) then try your memory stick when all is ready.
2. If evailable restore computer to an earlier date avail on windows 7, dont know about the rest.
3. Last resort - find the disc that came with your computer and nter it, this restors it to the way it was when you purchased it - problem solved.
good luck


I may have read your posting incorrectly - from your info it looks like a memory stick problem if the stick simply wont work in your original computer plus other computers - sory was barking up wrong tree
m
0
l
October 1, 2013 8:57:34 AM

i have the same problem sept i cant connect anything on my laptop like my webcam n now my memory stick ive tryed on my other computer still dont work :>?:( 

m
0
l
December 18, 2013 3:37:35 PM

Or, just buy a mac instead where everything works. I have to use these piece of Shsdf computers at work and I would like to smash them into 1000 pieces and send them to the Sun.
m
0
l
!