Sign in with
Sign up | Sign in
Your question

Worried that my new build has a faulty PSU

Last response: in Components
Share
January 5, 2013 10:51:00 AM

PSU: Seasonic X750
Motherboard: Asus _8Z77-V Deluxe
CPU : i7 3770K
GPU: EVGA GTX 670FTW + EVGA GTX650 for PhysX

Yes, its plugged into a very good UPS. And from what I've been told even with all the other expansion cards and drives in it, it should come nowhere near using up 750 watts.

The system I just built (and still haven't finished) used to run fine at first, kept it running for days and nothing wrong.

I was then trying to overclock the CPU, and after I got past the initial bluescreens due to the vcore being too low, I still couldn't maintain a stable overclock no matter what because eventually the system would fail and reboot due to the motherboard's Anti-Surge protection.... most of the time, a few times the system would just shut down and refuse to turn back on unless I either used the power button built-into the motherboard or unplugged it for a while.

So, assuming the overclock might be the problem, I resetted the motherboard to default settings and tried the burn-in tests (mainly Prime95 and IntelBurnTest) again just to make sure... it still happened... then happened again while I wasn't even taxing the system and just web-browsing on it.

So I turned it off and checked all of my connections, I noticed that one of the PCI-e connectors going into the modular bay of the PSU hadn't been inserted all the way. It was still fairly in there, but not far enough for the connector to click. I did so and checked all my other connections and tried again. Considering how far the connector already was in though, I doubted that was the issue.

Prime95 ran for 14 hours on blend mode with no problems, I was able to run several game demos with all settings maxed with no problems, the system had been running for over 24 hours now with no issues (it never even managed 10 hours before when it started spiking). Then just to be safe, I decided to run IntelBurnTest for 20 runs on Maximum while also running FurMark at highest 1080p settings to make sure my PSU can take it.

.... it rebooted due to a power spike within 10 minutes.

I have no idea what to do, I am assuming the PSU is faulty, but I just wanted to hear others opinions on the matter as well.

Could I have damaged something by trying to overclock? At 4.5Ghz I never let the vcore go above 1.345v or the CPU temps go above 92C, although 92C was a spike and usually even when running burn tests it was below 90C (and well well WELL below that when not burntesting).

Is it advisable to run IntelBurnTest on maximum for extended periods of time? (I calculated based on a 2-run that it would take 10 hours at 4.5ghz to finish 20 runs, not sure how long it would take on the stock 3.5) Did I screw up running both IntelBurnTest and FurMark on max at the same time? (The GPU is stock overclocked but otherwise I haven't messed with overclocking that).

Any help with this is appreciated, I just sincerely hope I didn't damage anything.
January 5, 2013 11:04:43 AM

Um 90 under prolong running it just to high ffs.
m
0
l
a b V Motherboard
January 5, 2013 12:18:58 PM

What CPU cooler do you have? 90 is too high...
m
0
l
Related resources
January 5, 2013 4:16:02 PM

Noctua NH-D14

Again though, this is on a 4.5Ghz overclock at a vcore of 1.345 running a torture test, at stock settings the temperature is around 50C on a torture test and 25-30C idle.
m
0
l
a b V Motherboard
January 5, 2013 6:31:32 PM

Dial down the overclock, sounds unstable.
m
0
l
January 5, 2013 6:44:19 PM

As I said, its running on STOCK settings right now, and I'm still getting the surge warnings.
m
0
l
a b V Motherboard
January 6, 2013 7:27:28 PM

Try resetting the bios with the button, jumper, or removing the cmos battery with the power unplugged. That will reset everything to stock. If it still does it then, I'd send it back.
m
0
l
!