Why is this happening?

Ok I have just built my first computer: http://pcpartpicker.com/ca/p/aSu3 I had it all together and it worked well for 1 day. It started flickering and then went black screen so I took out, removed drivers put back in and installed drivers. Whenever I have a driver installed my screen goes black. I can see my desktop and go on the internet without any driver for my video card, but I can't play any games. So when I try to install the driver so I can play games, it goes black screen. Why is this happening? I have installed beta 12.7 driver, as well as the 12.6 driver with no luck. What am I doing wrong? Is the graphics card a dud?
23 answers Last reply
More about happening
  1. jsut to be sure, is the IGP disabled on the build? and is the video cord connected through the GPU and not the mobo right?
  2. dudewitbow said:
    jsut to be sure, is the IGP disabled on the build? and is the video cord connected through the GPU and not the mobo right?

    The HDMI cord is through the video card and I have no idea what IGP means or if it is disabled
  3. igp= integrated graphics processor, the graphics on the actual cpu.
  4. dudewitbow said:
    igp= integrated graphics processor, the graphics on the actual cpu.

    I think it is enabled because I was able to play minecraft without my graphics card in my computer. How do I disable it?
  5. you disable igp in the bios when you boot the computer
  6. dudewitbow said:
    you disable igp in the bios when you boot the computer

    Ok and should my video card be in my comp when I do this?
  7. normally yes. it should
  8. dudewitbow said:
    normally yes. it should

    Ok I have done that and am now at my desktop. Now I can't play any games untill I get a driver. http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_vista64.aspx Do I get the 12.7 beta patch or the other one. Or both??
  9. first thing to do for sure in my opinion is to download driver sweeper.

    Delete ALL of the drivers for AMD then reset the computer. Then stall new drivers, whichever version you would prefer to be installed. then restart again.
  10. dudewitbow said:
    first thing to do for sure in my opinion is to download driver sweeper.

    Delete ALL of the drivers for AMD then reset the computer. Then stall new drivers, whichever version you would prefer to be installed. then restart again.

    Yeah I have used driver sweeper. So it doesn't matter if I install the beta patch or the Catalyst install manager thing? They're both the same?
  11. any version of catalyst is fine. what beta usually means is that its still in testing, and may possibly need tweaks for a few models of gpus
  12. If you can play Minecraft, or use your computer at all, without your graphics in the computer, then you have an IGP. Make sure that your monitor is connected to the graphics card, and not the motherboard.
  13. I have not had any problems with the 12.7 beta drivers so you should be fine but of course your mileage may very.
  14. dudewitbow said:
    any version of catalyst is fine. what beta usually means is that its still in testing, and may possibly need tweaks for a few models of gpus

    Ok so I unistalled all AMD Drivers in safe mode with my graphics card out, then I put back in and plugged my HDMI cable into my graphics card and installed the Catalyst thing. As soon as it was finished installing it said complete with some errors. (View Log) So I looked at the log and it didn't show any. After that I restarted my comp like it asked me to and I had black screen . EDIT : And the intergrated graphics are OFF.
  15. bryce6622 said:
    Ok so I unistalled all AMD Drivers in safe mode with my graphics card out, then I put back in and plugged my HDMI cable into my graphics card and installed the Catalyst thing. As soon as it was finished installing it said complete with some errors. (View Log) So I looked at the log and it didn't show any. After that I restarted my comp like it asked me to and I had black screen . EDIT : And the intergrated graphics are OFF.



    the log is not showing any errors? that would be an extremely abnormal situation.
  16. dudewitbow said:
    the log is not showing any errors? that would be an extremely abnormal situation.

    I will try it again and try to get a screenshot to show you
  17. dudewitbow said:
    the log is not showing any errors? that would be an extremely abnormal situation.

    Ok now When I unplug my video card and turn on my comp it makes 5 beeps or so. Now I can't even get to my desktop at all?
  18. bryce6622 said:
    Ok now When I unplug my video card and turn on my comp it makes 5 beeps or so. Now I can't even get to my desktop at all?


    I would assume its trying to look for a video card, as you now have IGP off.
  19. dudewitbow said:
    I would assume its trying to look for a video card, as you now have IGP off.

    So how am I supposed to fix it?
  20. bryce6622 said:
    So how am I supposed to fix it?


    if the card is doesnt work, and you cant see bios to turn on igp again, you will have to CMOS reset.(google if you dont know how to cmos reset) what it does is restore all hardware but HDD to factory settings.
  21. dudewitbow said:
    if the card is doesnt work, and you cant see bios to turn on igp again, you will have to CMOS reset.(google if you dont know how to cmos reset) what it does is restore all hardware but HDD to factory settings.

    Man things are going from bad to worse. I guess I will try that tomorrow
  22. dudewitbow said:
    if the card is doesnt work, and you cant see bios to turn on igp again, you will have to CMOS reset.(google if you dont know how to cmos reset) what it does is restore all hardware but HDD to factory settings.

    Ok I have CMOS reset and can now see my desktop. It seems everytime I install a driver onto my video card my screen goes black. Is my video card a dud?
  23. try older versions of catalyst, like 12.4 or less. I've had similar issues but on laptop.
Ask a new question

Read More

Graphics Cards Drivers Graphics