Sign in with
Sign up | Sign in
Your question

HDTV as PC Monitor blurry text problem

Last response: in Graphics & Displays
Share
July 3, 2012 4:49:19 PM

Hey guys,

new to the forum but I have read other articles concerning this topic with a bunch of different answers that do not seem to be working. Basically I have a HDTV as an extended monitor in my office at work and all text shows up blurry on the tv monitor. I use the monitor to view construction plans and do work on them electronically, so the blurry text makes it nearly impossible to use. The IT guy here at work has it hooked up via HDMI, but also have tried VGA. Im no computer genius but I know some basics. If anyone has a solution it would be great.

Here are the specs

Monitor: Toshiba 40L5200U 40" LED 1080p 120 HZ
COmputer" Dell Optiplex 380
Connection: HDMI
Resolution for monitor set to 1920 x 1080
a b C Monitor
July 3, 2012 5:43:03 PM

Start by manually checking or setting the resolution and refresh rate on the computer.

Control panel
display
adjust resolution
click on monitor 2
the resolution should be 1920x1080.
click advanced
monitor
Try a refresh rate of 60, or even 59. If that does not help try 120.
m
0
l
Related resources
July 3, 2012 5:48:16 PM

Is there a PC mode setting on your TV? Someone with a similar problem the other day found that to be the issue.
m
0
l
July 3, 2012 6:10:43 PM

When I was shopping monitors on Amazon I remember reading a post/solution about blurry text and one of the steps in additon to the monitor setup was to go in to the GPU interface and making a setting change as well. Sorry can't remember the details.
m
0
l
July 3, 2012 6:21:48 PM

1. The setting to the monitor is 1080 x 1920 32 bit true color 60 hz (there is no 120 option)

2. I will try the clear type calibration.

3. There is a PC input on the computer, it is the VGA input, the IT guy said it made the picture look worse (he did it over the weekend and I wasnt in the office).

I also read somewhere on these forums that if you just name the HDMI input to PC that this fixes the problem, however Toshiba has preset options to name inputs and since there is already a seperate PC input, there is no option to rename a HDMI to PC
m
0
l
July 3, 2012 6:31:35 PM

By PC Mode, I mean a setting you can enable in the TV menu system (not the port), much like you would find a theater mode setting. (Sorry for being a little unclear)

I'm pretty sure it just disables all the post processing that is built in to the TV to make TV/Movies look sharper.
m
0
l
July 3, 2012 6:41:02 PM

Oh I found it there. That actually did help a bit, it darkened the screen which made the font a bit clearer. I wouldnt say its 100% but that was an improvement
m
0
l
July 3, 2012 6:41:31 PM

There is also an option in the menu>settings called "pc settings" but for whatever reason I cant select it?
m
0
l
July 7, 2012 8:27:32 AM

Part of the problem is that TVs aren't great at text, that is why we have computer monitors.
m
0
l
July 26, 2012 6:19:34 PM

thee_prisoner said:
Part of the problem is that TVs aren't great at text, that is why we have computer monitors.


I disagree. Although there are differences between a "TV" and a "Monitor" they have nothing to do with how the text displays due to any hardware issues.

http://www.engadget.com/2007/01/19/ask-engadgethd-what-...

The blurry text is due to a setting somewhere, he just hasn't found it yet. A TV can be used as a monitor with perfect text, it just has to have the right input, the right settings on the TV, and the right settings on the video card. I have two TVs I use as a monitor, and they are indiscernable for my 3rd display, which is a "PC Monitor".

Here is ONE example of a solution when many complained of blurry text. I hope it works in this case:

Copied from a review on Amazon.com.

"Most Helpful Customer Reviews


384 of 397 people found the following review helpful
5.0 out of 5 stars GREAT PC MONITOR --- Please READ!!!, June 19, 2010
By Tech Junkie - See all my reviewsThis review is from: Samsung P2770HD 27-Inch 1920x1080 5ms 16.7M LCD HDTV Monitor (Electronics)
Ok, I'm one of those who always want to get a product that can be used for different purposes and Samsung P2770HD LCD TV sparked my interest. This review is for those who keep saying this is not a good PC monitor (I can tell you right now that you are WRONG). I bought this and hooked it up using HDMI. I was initially surprised the reviews are right. Text seemed blurry but I DID NOT GIVE UP because I saw tons of MENU adjustments so I played around with it. I'm telling you once you do this, you will love this monitor and get it over its 2770H (no TV tuner) brother or any other dedicated LCD monitor.

----------------------------------------------------------------
I repeat, this unit is perfect as a PC Monitor using HDMI cable!
----------------------------------------------------------------

*** Before you read on, I'm assuming you have connected this to your PC using HDMI cable and you have the LATEST video card drivers for your PC. Don't even bother with the SAMSUNG drivers yet. You don't need those at the moment. Set your resolution to 1920x1080 before starting (if your video card can support it, most does!)

Here's what you do: (and you can do this while you're PC is ON up so you can see the display change right before your eyes!)

1. Open MENU
2. Go to "Input"
3. Select "Edit Name" to open up the "Edit Name" sub menu.
4. Scroll down to "HDMI" and select it, (watch carefully)
5. Now assign "PC" or "DVI PC" to the HDMI setting and voila!!!
*** I'm not sure what this setting is for, I thought it was just to give it some "name" assignment. But somehow changing this corrected the blurry/blocky text effect.

After this, your PC display should be perfect. If text is still blurry, check if the display/resolution fills the entire screen. If not, this has to do with video card scaling option which can be easily adjusted from the video driver configuration. If you are using an ATI based video card, do these additional steps. (NVidia based video cards should also have an equivalent for this).

For WinXP
*********
1. Open up Catalyst (video card configuration tool)
2. Go to DTV or DTV (DVI) menu on the left.
3. Select sub menu "Scaling Options" and set slider to "0%" towards "Overscan"
4. Done! PICTURE IS PERFECT!!!

For Windows7/Vista
******************
1. Open up Catalyst (video card configuration tool)
2. Pull down Graphics menu
3. Select "Desktop & Displays"
4. Right click on the monitor icon at the bottom of the screen that appears.
5. Select "Configure..."
6. Change the scaling options same as the above.

Note: I'm not a MAC user so I don't know how the video configuration looks like for ATI in MAC. Probably any one of the 2 above.

Enjoy this monitor!

I can switch input sources PC/TV, turn the unit on and off and the picture is ALWAYS PERFECT.

For those who gave this unit poor reviews as a PC monitor, I'm sorry but you just gave up on one solid product that can be both a TV and a damn good PC monitor. Those who complained about dead pixels or backlight leaks (that is of course another story and you may have gotten a bad unit). Sound is reasonable for me. Just get a good external speaker (cheap) and you're done! You have 2 choices for audio out anyway (3.5mm and optical out). For it's price, this simply gives you more bang for the buck.

---------

UPDATE: I noticed that for ATI video card drivers, installing the "driver only" will not show scaling option in the settings. I recommend downloading/installing the entire catalyst software to enable this option. Because I don't have any NVidia hardware at the moment, I'm not sure if NVidia's custom driver installation will have any effect on scaling options.

Also be mindful if you're using an external HDMI switch/box. Low quality HDMI switches may show some screen artifacts so be sure to test the monitor first using a direct HDMI connection, then return the HDMI switch after you've finalized your driver settings. "
m
0
l
!