Sign in with
Sign up | Sign in
Your question
Solved

[Solved] GTX 680 Core Clock Problem

Last response: in Graphics & Displays
Share
July 3, 2012 11:06:04 PM

Hey everyone. I recently bought a Gigabyte GTX 680 2gb OC and installed it. I'm going to be honest and say I don't really understand how overclocking works. However, the GTX 680 was advertised as being Overclocked to 1071 MHz However, running MSi Afterburner, the core clock is always stuck at 705-706. I made sure to boot up a heavy intensive game (Battlefield 3) and went back and checked, and it still shows it always being stuck at 706.

Here is a picture of my MSI:





Here is my card here btw:

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

I haven't touched any of my settings. The card is brand new. I upgraded my Nvidia Drivers to 301.42

Any help would be greatly appreciated.

EDIT:

My specs are:

Intel i5 2320 3.2ghz

8 Gb Ram

1000 Watt PSU
a c 536 U Graphics card
July 3, 2012 11:15:38 PM

Ditch those 301.42 drivers and do a clean install using the 304.48's.

What game are you using that eats up over 2GB of memory?
Related resources
a c 536 U Graphics card
July 3, 2012 11:32:49 PM

Yep, go to the Nvidia driver website and go for the "beta" drivers option. When you install the drivers, there is a check box for "Clean Install". You might as well go for the 304.79 drivers just released today.
http://www.nvidia.com/Download/Find.aspx?lang=en-us
July 3, 2012 11:35:20 PM

Okay, thanks a ton. Let me install this, and I'll report back. :) 
July 4, 2012 12:18:28 AM

Alright, I upgraded to the new driver. And it still stuck at 706 mhz. I have no idea why. Maybe my card is defective?

Or maybe Msi is reading it wrong. Although in EVGA's Precision X, it too shows a cap at 705 mhz.

July 4, 2012 12:35:59 AM

Alright I'm a dunce. My version of Msi Afterburner was 5 months old. I just updated, and now my settings have changed. I think it's fixed.



Yup! My clock got up to 1124

Just glad it's working. I still find it bizarre how both Nvidia Control Panel and Msi listed my card as being 705 mhz (for core clock) - when my edition said it was Overclocked to 1074 mhz out of the box.

Is this something to still be worried about, or am I good to go?

And on that note, how high should I push the MHz on this card? Just go up in increments of + 5 (I'm on +45 now) and make sure its stable?

EDIT: My updated Nvidia driver Panel now reflects my MHz correctly.
July 4, 2012 1:55:36 AM

17seconds said:
It might have been the driver update. Weird clocks has been a common issue with those 301.42 drivers, fixed in the 304's.

My understanding of Kepler overclocking is to increase the power limit to max, then begin increasing the offset, up to around 1200 mhz seems common. Here are a couple guides:
http://www.hardocp.com/article/2012/04/04/nvidia_kepler...
http://www.guru3d.com/article/geforce-gtx-680-overclock...


This is great thanks!

I'm currently hitting 45-60fps on Skyrim and 55-60 in Battlefield. Which is great. But I'm wondering if my i5 2320 is holding me back. Was kind of hoping to get a constant 60 at least maybe 70-80. Maybe that was unrealistic.

My gtx 580 was getting similar numbers, which is why Im disappointed. But the reason I upgraded 680 vs 580 SLI is my brother had a very poor card so I wanted him to get up to date, so I gave him my 580. Kind of wondering if I should have just got another 580 and saved money since the performance is similar.

I'll try this guide though and see if I can get an improvement.

Best solution

a c 536 U Graphics card
July 4, 2012 2:40:01 AM
Share

I think your CPU is fine.

Skyrim is a tough game to gauge performance with. With mods, and depending on the location, the framerates can vary considerably.

Are you using Adaptive VSync? If so, that could be why your framerates are not going above 60. Turn it off to see if you get higher numbers. If you do use VSync, be sure to use Adaptive VSync, it's way better than regular VSync.

Here is a good Skyrim tweading guide. You can find lots of other good info and tweak guides in there as well.
http://www.geforce.com/Optimize/Guides/the-elder-scroll...
July 4, 2012 3:08:58 AM

Wow, that did the trick! Getting 80-100 FPS on Skyrim now and I'm not getting a single screen tear.

Thanks so much for pointing that out to me. I actually think I have V Sync on Battlefield 3 as well.

Okay, well I think it's time to close the thread. I've solved all my issues, and you have been extremely helpful. :) 
July 4, 2012 3:09:07 AM

Best answer selected by satanigatan.
!