Sign in with
Sign up | Sign in
Your question

Is this a problem with my CPU or GPU?

Tags:
Last response: in CPUs
Share
January 7, 2013 8:07:46 AM

I really don't know if it's the GPU or the actual CPU, so I'll just post this here for now.


I usually play modern games on medium, games like Far Cry 3 on medium and Max Payne 3 on high (only to find fps drops in some large areas, like the swamp) Chivalry Medieval Warfare runs pretty smooth on high, that is of course when theres 20 players on a server. I may have to turn down the graphics if there are 50 players total in one server.

I notice when theres a drop, the animations in the game itself isn't actually "slow" but my screen and mouse feels all weird. Anyways, here's my specs:

CPU: AMD FX-4100 Quad 3.6Ghz
PSU: Silver Power SS500 500w
Motherboard: Asus M6A78L - M LX V2 socket AM3+
Ram: DDR3 133Mhz 4GB
GPU: Sapphire Radeon HD6870 1GB DDR5
SSD: Samsung SSD 830 series 128GB
HDD: WD Caviar blue 500GB

I think the problem is the CPU, maybe I should get a Phenom ll x4/x6? If so, can you guys give me some tips? I've been thinking of Phenom ll x6 1090T, maybe too much? The main reason I think that is because I tried Serious Sam 3 with all settings high, the fps went somewhere between 40-70 overall. When I set CPU memory to medium and GPU memory to medium, leaving only GPU performance on high, I may gain around 10-20+ fps. But this drops down quickly when I enter large areas.

Any suggestions would be appreciated, I will check the thread in the morning. Thanks in advance!

More about : problem cpu gpu

a b à CPUs
January 7, 2013 8:16:17 AM

Probably need a new CPU and more ram and probably a PSU as well.
a c 148 à CPUs
January 7, 2013 11:44:07 PM

40-70 on SS3 is perfectly normal for your 6870. You can turn off shadow AA for a nice boost.
!