Sign in with
Sign up | Sign in
Your question

Rig with ATI Radeon 6870 Stuttering in Diablo 3

Last response: in Graphics & Displays
Share
July 5, 2012 6:11:09 AM

Hi guys,

Bought an MSI ATI Radeon r6870 yesterday to help improve my gaming experience with Diablo 3. I made a fresh install of Windows 7 Ultimate along with a fresh install of D3 on my new SSD. I am running on 8GB of RAM and never usually have any problems with any other games.

In the ATI CCC I set a majority of my settings towards Peformance instead of Quality. With those settings whenever i try to play D3 at its highest settings there is alot of stuttering but when i turn shadows off in the game there is almost no lag except when I am killing maybe 20+ mobs at a time.

However, from videos that I have seen on youtube and etc. Rigs that are lesser than mine seem to be having no lag at all when playing at max settings even with shadows on and even when they switch shadows off they do not lag at all when facing a large group of mobs.

Any help will be greatly appreciated!
July 5, 2012 6:25:11 AM

whats your cpu?
m
0
l
July 5, 2012 6:27:43 AM

i7 920 @ 2.67GHz (8 CPUs)
m
0
l
Related resources
July 5, 2012 6:29:51 AM

try running 3dmark11.
m
0
l
July 5, 2012 6:30:42 AM

Alright, what kind of score should i be looking for?
m
0
l
July 5, 2012 6:47:34 AM

it should allow you to compare with people with similar specs.
m
0
l
July 5, 2012 9:11:10 AM

the 3dmark score looks perfectly normal. You might want to check your CCC settings and try to change everything back to default.

A cpu overclock might give better performance with shadows on.
m
0
l
July 5, 2012 9:17:54 AM

Should i overclock the speed of the GPU as well in CCC?
m
0
l
July 5, 2012 9:20:31 AM

At the moment I am trying to reinstall the drivers, I managed to uninstall CCC but in Device Manager whenever i uninstall the Display Adapters they Windows just automatically finds the drivers and installs them again, so once i fix this I will try what you suggested.
m
0
l
July 5, 2012 9:23:22 AM

You might have some major malware on your PC.

When you search for something do the ads in web pages immediately show products similar to what you searched for?
m
0
l
July 5, 2012 9:25:07 AM

I'm pretty sure everything is okay ananan because this is all a fresh installation and etc. there's about 5 programs installed atm, Chrome, Diablo 3, 3dmark, and some other benchmarking stuff, that's all.
m
0
l
July 5, 2012 3:58:37 PM

Try a CPU OC , I wasn't too happy with my 6870 too, untill I OC'ed my CPU from 2.8 to 3.7 , Aligned my 3D Mark Vantage score to what reviews had.
m
0
l
July 6, 2012 1:21:44 PM

I'm running fullscreen and I have just ran benchmark tests and etc. and I am scoring 400-500 in 3dmark11 then other users with the same GPU. Really not sure what's going on now. This is really annoying especially when I am trying to record some footage, the fps fluctuates so randomly it doesn't even make sense. I've checked almost everything I could, checking GPU Temperatures (it's around 60-80 degrees celsius) tried changing the different CCC settings from Performance to Quality and etc. (This doesn't make much of a difference sometimes i even notice that setting everything to Quality actually makes the random drops in FPS less).

I have also overclock my i7 920 @ 2.6Ghz to around 3.2 Ghz. Many are saying that it could possibly just certain problems with the game itself, However, I still see alot of people streaming/posting up HQ vids and etc. and even some friends playing the game without having any problems whatsoever with fps drops.
m
0
l
July 6, 2012 1:42:19 PM

I usually never reccomend playing around with CCC settings. Also if you record it usually drops performance a lot.Are you up to date on all the game patches? Have you tried a full wipe of drivers using Driver Sweeper?
m
0
l
July 6, 2012 1:49:35 PM

Yes, as i mentioned earlier I made formatted everything made a new installation of Windows, all the latest drivers and etc. Everything is up to date, really getting even more confused now, hahah.
m
0
l
July 6, 2012 1:53:04 PM

What PSU do u have ?
m
0
l
July 6, 2012 2:08:45 PM

Use the 12.7beta drivers... they are exceptional drivers.

1) Download Driver Sweeper here.
2) Download Catalyst 12.7beta drivers here but don't install.
3) Custom uninstall AMD software through the "Control Panel" and select everything and reboot.
4) Run Driver Sweeper and clean AMD drivers and reboot.
5) Re-install CCC and reboot.
m
0
l
July 6, 2012 2:46:25 PM

RussK1 said:
Use the 12.7beta drivers... they are exceptional drivers.

1) Download Driver Sweeper here.
2) Download Catalyst 12.7beta drivers here but don't install.
3) Custom uninstall AMD software through the "Control Panel" and select everything and reboot.
4) Run Driver Sweeper and clean AMD drivers and reboot.
5) Re-install CCC and reboot.


How do i stop Windows from auto-installing the Display Adapters for the graphics card? I've turned off PnP and the Device Manager/Windows Auto Update for drivers and etc. It's pretty annoying, I will try your fix if I can figure out how to stop the auto-installs by Windows 7.

I am running a 1000W PSU.
m
0
l
July 6, 2012 3:08:06 PM

Getting this error when trying to install the 12.7 beta drivers.


AMD Display DriverFinal Status: Fail
Version of Item: 8.981.2.0000
Size: 90 Mbytes
HDMI/DP Audio DriverFinal Status: Fail
Version of Item: 6.58.0.6606
Size: 1 Mbytes

Error messages
Driver Install: the driver package does not specify a hardware identifier
Driver Install: the driver package does not specify a hardware identifier


m
0
l
July 6, 2012 7:58:32 PM

mindtrip said:
How do i stop Windows from auto-installing the Display Adapters for the graphics card? I've turned off PnP and the Device Manager/Windows Auto Update for drivers and etc. It's pretty annoying, I will try your fix if I can figure out how to stop the auto-installs by Windows 7.

I am running a 1000W PSU.


Yes it is, but there is a simple fix for that.


1) Open Start
2) Right Click "Computer" and select "properties"
3) Left Click "Advanced System Settings"
4) Select the "Hardware" tab at the top
5) Left Click "Device Installation Settings"
6) Select "No, let me choose what to do"
7) Select, "Never install driver software..."

Then repeat my previous post.

After you install drivers you can then put device installation settings back to default.
m
0
l
July 7, 2012 2:41:28 AM

That's exactly what I've done and everything seems to be running smoothly now, I had to make a fresh install of Windows though, was having too many problems with the previous drivers not wanting to disappear lol.

There might have been a slight improvement but overall there still seems to be issues. Still a drop in fps whenever there's about 20 mobs that come into my screen.
m
0
l
July 7, 2012 9:29:35 AM

make sure you run the game off the ssd and record onto your HHD if you are recording.
m
0
l
!