Sign in with
Sign up | Sign in
Your question

GTX 460 video flashing/stuttering

Last response: in Graphics & Displays
Share
July 5, 2012 7:16:16 AM

So I just got a Galaxy GTX 460, this model: http://www.amazon.com/gp/product/B003VKGZSM

Games run great, any 3d application runs perfectly, and much better than my old HD 4850. However, when I play video (in VLC, Chrome, Firefox, etc.), the video will randomly become distorted or skip for one or two frames. Audio is fine. It only happens every few seconds, and seems to happen more so with HD video. I noticed the problem on the 301.42 driver and after downloading the beta 304.48 driver it seems to happen less frequently (which could just be my imagination) but it still occurs. It happens with default settings on both drivers, and I've tried playing around with the video settings endlessly; nothing helps. I've even tried downloading an older driver (285.27) and the problem still occurs. I can't imagine what the solution would be though, considering games play flawlessly.

Here are my specs:

Win7 64bit (yes, using 64bit driver)
Intel Core2Quad Q8200 @ 2.33GHz
4 GB DDR2
Biostar GF7100P-M7S

Monitor is a 1680x1050 Westinghouse LCM-22w3
July 5, 2012 8:42:25 AM

So I managed to capture video of this happening: http://www.youtube.com/watch?v=Uin4PLnT8ng

It happens once near the beginning around 0:05, and again at 0:33. The second one is more visible. Again, this happens EVERY TIME, with every video player, including VLC and the Chrome flash plugin.
July 6, 2012 6:54:32 AM

Update: I managed to fix this problem in my browser (Chrome) for youtube videos, by disabling hardware acceleration. So I've been looking for a way to fix it for VLC/other video players as well. My setting for hardware acceleration in VLC is already disabled. The 'change settings' option in Display>Troubleshoot is grayed out. There is no option to disable it in DXDIAG, but DirectDraw acceleration, etc. is enabled. I've tried disabling Aero, it's still grayed out and there's no options in DXDIAG. I've tried comparability mode. I've tried Media Player Classic, which seems to just play worse. What do I do now?
July 6, 2012 7:33:53 AM

Well, managed to fix this finally. Turns out there are TWO hardware acceleration options in VLC: "Accelerated video output" and "Use hardware YUV>RGB conversions". Disabling both of these fixed my problem entirely.
!