Sign in with
Sign up | Sign in
Your question

Inexplicable drops in GPU load causing massive FPS drops.

Last response: in Graphics & Displays
Share
July 6, 2012 2:56:44 PM

I'm running a Dell Precision M6500 laptop with the following specs:

CPU: Intel Core i7-720QM Clarksfield @ 1.60GHz
GPU: Nvidia Quadro FX 2800M
RAM: 8GB DDR3
OS: Windows 7 Professional SP1 x64

When I run games such as Diablo 3 or Battlefield 3 they run perfectly smooth the first couple of minutes, but then suddenly drop to unplayably low FPS.
I've checked just about everything I could think of, and I cannot for the life of me figure out why this is happening.

After installing OCCT monitoring software and running GPU-Z, I tried running a stress test on the GPU, and it showed that after just over a minute, the FPS would drop to half. At the same time, the GPU load % would drop to about 50%, while CPU load would increase drastically. There was barely any change in temperatures, and all voltages and clock timings stayed the same. The only change was GPU and CPU load percentages.

The laptop is plugged in, running high performance power settings.
I've tried newest drivers and I am currently running the drivers in this post: http://www.techpowerup.com/forums/showthread.php?t=1375...

The problem persists regardless of wireless/cabled network and location.

DxDiag: https://www.dropbox.com/s/125vs1wv3lnifvn/DxDiag.txt
GPU-Z log: https://www.dropbox.com/s/yjqy5aa5lrrsd6q/GPU-Z%20Senso...
OCCT graphs: http://imgur.com/a/KrJyd

Other things I've tried:

- Updating DirecX
- Updating .net Framework
- Disabling Hyperthreading
- workaround to disable Intel Turbo Boost
- disabled Core Parking in the windows registry
- disabled SpeedStep

Any help is greatly appreciated.

More about : inexplicable drops gpu load causing massive fps drops

July 6, 2012 3:00:21 PM

have you tried enabling fixed or dynamic mode and turned off any power saving features in your bios?
m
0
l
a c 456 Î Nvidia
July 6, 2012 4:54:20 PM

If it only happens when running OCCT, then it is likely the GPU throttling itself down to prevent damage. Run a normal game, rather than a stress test, and see if it continues to happen.
m
0
l
Related resources
July 6, 2012 4:54:32 PM

There are no options referencing fixed or dynamic mode in the bios, and of the other power settings only SpeedStep was not disabled. So I'm going to try to disable SpeedStep and see what happens.

edit:
Disabling SpeedStep didn't change anything for the better, more to the contrary, in fact.
m
0
l
July 6, 2012 5:06:58 PM

It happens while running games like Battlefield 3 and Diablo 3 as well, not only when running OCCT.
(also, the core, memory and shader clocks in addition to the vddc remain unchanged during the test)
m
0
l
a b Î Nvidia
July 6, 2012 5:08:28 PM

The Quadro FX cards use firmware that is designed to completely render an entire scene without regard to the resulting framerate. GeForce cards will automatically terminate unnecessary rendering operations in order to improve performance. This is by design, there is nothing that you can do.
m
0
l
July 6, 2012 5:17:16 PM

Pinhedd said:
The Quadro FX cards use firmware that is designed to completely render an entire scene without regard to the resulting framerate. GeForce cards will automatically terminate unnecessary rendering operations in order to improve performance. This is by design, there is nothing that you can do.


While I don't doubt your statements about the cards' designs, I am reluctant to believe this is the root of my problem.
The reason is that this is a new problem.
I've been able to play just fine in the past on the same laptop. The only things that have changed are drivers and installed games.

It might be a hardware fault, or possibly some corrupted drivers or system settings, but this problem is not caused by design.

Though I don't know exactly when the problem started happening, I suspect it was around the time Diablo III was released.

(edit: I played BF3 just fine before this started happening, now it suffers a brutal drop in fps after a couple of minutes.)
m
0
l
a c 456 Î Nvidia
July 6, 2012 8:13:01 PM

Be sure to update your drivers to the latest betas and do a clean install. Can't hurt and often will fix the problem.
m
0
l
July 6, 2012 8:56:54 PM

Those logs were kinda hard to parse, but after about half an hour of testing, the only processes and services that showed consistent activity at the time of the drop were the bluetooth services and rundll32. (The latter accessed the registry to fetch time zone data)

I tried disabling bluetooth, but nothing changed. :\

Thanks for the help =)
m
0
l
July 6, 2012 8:59:03 PM

17seconds said:
Be sure to update your drivers to the latest betas and do a clean install. Can't hurt and often will fix the problem.


Yeah, battlefield complained about the older drivers, so I performed a clean install of the newest verde drivers, but still no change. :<
Still, can't hurt.
m
0
l
a b Î Nvidia
July 7, 2012 6:40:48 AM

luxuselg said:
Yeah, battlefield complained about the older drivers, so I performed a clean install of the newest verde drivers, but still no change. :<
Still, can't hurt.


That's because those drivers aren't designed for gaming. The optimizations that make into the GeForce drivers don't necessarily make in into the Quadro drivers and vice versa.
m
0
l
July 7, 2012 7:21:53 AM

Most likely throttling due to heat, Have you cleaned out your fans?
Blowing compressed air through the vents from the outside doesn't count - your just blowing the dust, lint, hair buildup into the fan blades and when you start it back up it blows right back against the fins blocking airflow. :non: 

I dont see any logs with cpu temps but 71c for the gpu is fine.
I suspect the cpu throttling back is the issue. You can also try going into power options in the control panel and setting it up on high performance profile and see how it acts. even though you turned off speedstep in the bios I have seen win 7 ignore this and throttle back the cpu.
Core Temp can be used to monitor your cpu, they also have a gadget you can install in windows 7 :sol: 

With all that being said 1.6ghz base clock may proove to be a little weak how far does it turbo boost to?
I have an older Alienware M9750 that originally had a 1.66 core 2 duo and I replaced the bad geforce 7950 with a Radeon 3870 gpu and it wouldnt run D3 even on low settings without crashing I installed an older driver and solved the crashing, (it seems the drivers were too agressive on the gpu) this solved the crashing but not the low fps.

I upgraded to an unlocked T7600g@2.33ghz it would run but low fps, But overclocking the gpu had little effect besides driving the heat up. Using set fsb I overclocked the cpu to a little over 2.5ghz and solved the issue I can now run it an max settings with 40+ fps turn down shadow quality and it jumps to 50+fps so it seems to have been a cpu bottleneck for me.
m
0
l
July 7, 2012 5:37:36 PM

Tremec said:
Most likely throttling due to heat, Have you cleaned out your fans?
Blowing compressed air through the vents from the outside doesn't count - your just blowing the dust, lint, hair buildup into the fan blades and when you start it back up it blows right back against the fins blocking airflow. :non: 

I dont see any logs with cpu temps but 71c for the gpu is fine.


The OCCT graphs include CPU temperature and clock speeds (http://i.imgur.com/sl3g0.png and http://i.imgur.com/agdJ8.png)
CPU temps don't rise above 70C, so I don't think that's the issue.

Tremec said:
I suspect the cpu throttling back is the issue. You can also try going into power options in the control panel and setting it up on high performance profile and see how it acts. even though you turned off speedstep in the bios I have seen win 7 ignore this and throttle back the cpu.


It doesn't seem like the CPU is being throttled, but I'm not sure. The laptop has been in High Performance profile since day one.

Tremec said:
With all that being said 1.6ghz base clock may proove to be a little weak how far does it turbo boost to?
I have an older Alienware M9750 that originally had a 1.66 core 2 duo and I replaced the bad geforce 7950 with a Radeon 3870 gpu and it wouldnt run D3 even on low settings without crashing I installed an older driver and solved the crashing, (it seems the drivers were too agressive on the gpu) this solved the crashing but not the low fps.

I upgraded to an unlocked T7600g@2.33ghz it would run but low fps, But overclocking the gpu had little effect besides driving the heat up. Using set fsb I overclocked the cpu to a little over 2.5ghz and solved the issue I can now run it an max settings with 40+ fps turn down shadow quality and it jumps to 50+fps so it seems to have been a cpu bottleneck for me.


I've been running battlefield 3 just fine on this laptop earlier, so I know it can run the game smoothly.
m
0
l
July 7, 2012 5:40:56 PM

Pinhedd said:
That's because those drivers aren't designed for gaming. The optimizations that make into the GeForce drivers don't necessarily make in into the Quadro drivers and vice versa.


It used to be like that, but the new Verde drivers are the same for both GeForce and Quadro cards, atleast in notebooks.

http://www.nvidia.co.uk/object/notebook-win7-winvista-6...
m
0
l
a b Î Nvidia
July 7, 2012 5:48:50 PM

luxuselg said:
It used to be like that, but the new Verde drivers are the same for both GeForce and Quadro cards, atleast in notebooks.

http://www.nvidia.co.uk/object/notebook-win7-winvista-6...


Verde is simply a distribution method for mobile GPUs. The actual driver suite that gets installed which includes the optimizations present in both the Quadro and GeForce lineups depends on which card is present in the system. Its similar to how the same driver suite is used for all desktop graphics cards.
m
0
l
July 7, 2012 6:35:44 PM

Well your card is not
on the supported cards list or the unsupported cards list for D3 and according to the mobile graphics card list itshould run the game.
A few threads in the D3 forums are suggestiong to turn down the resolution to 1280X1024 and try it there as the bandwith on the Quadro card is not as high as the desktop versions.
I usually start by turning everything all the way down and start turning settings up to max one at a time and watching the FPS to see what is impacting it the most.

Also of note go to performance information and tools and re-run the performance assessment and post the results here, I have found this to be a good indicater if there is a driver, Direct X, or other issue.
for referance my laptop is
CPU: 6.0
Memory: 6.0
Aero perf 6.9
gaming 6.9
harddrive 5.9

This is with the GPU undervolted and a 5% underclock as the CPU is the bottleneck on my system I undervolted and underclocked to save heat and power at stock speeds it was rated at 7.1 your GPU is a tier higher than mine and should be in the 7.3+ range.
m
0
l
July 7, 2012 10:13:00 PM

Are you running Windowed or Fullscreen? If Windowed, try Fullscreen and also try turning off Aero. Some applications try to avoid glitching by dropping into a throttling mode. If the GPU can't meet its budget of rendering a frame in 16ms, it will switch to an alternating mode where it only renders every other frame. I think DWM may do this and you may be running into a combination of this behavior and a driver issue, perhaps the issue with Quadro drivers that Pinhedd has pointed out. It is strange that it happens in more than one app/game, which is what makes me wonder about DWM being the issue.
m
0
l
!