Game requesting "graphics card which supports shader model 3 "

Hello,
I have recently purchased a game and it is not allowing me to play it as it says that I need to get a graphics card which supports shader model 3.

My adapter is currently: ATI Radeon X300/X550/X1050 Series

Colour quality: 32 bit (High)

My computer is a Windows XP Home Edition.

I'm not totally sure of what information to include but I would be very grateful of any help you can offer me.
20 answers Last reply
More about game requesting graphics card supports shader model
  1. it seems to me you need a new video card.

    shader models are supported by video cards. if i remember correctly yours only goes up to 2.0
  2. +1 your video card is just too old.
  3. Your graphics card does not support shader model 3. Nothing you can do about it with your current card.

    Following cards support shader model 3

    AMD Radeon:
    X1300 + series
    HD 2000 / 3000 / 4000 / 5000 / 6000 / 7000 series

    Nvidia GeForce:
    6000 / 7000 / 8000 / 9000 series
    100 / 200 / 300 / 400 / 500 / 600 series
  4. Anonymous said:
    Your graphics card does not support shader model 3. Nothing you can do about it with your current card.

    Following cards support shader model 3

    AMD Radeon:
    X1300 + series
    HD 2000 / 3000 / 4000 / 5000 / 6000 / 7000 series

    Nvidia GeForce:
    6000 / 7000 / 8000 / 9000 series
    100 / 200 / 300 / 400 / 500 / 600 series


    What is the best way to update it?
  5. What would be the best way to update it?
  6. the best way is to buy yourself a new card :-| U need a new PC by the looks of it
  7. Who sells them?
  8. eag270 said:
    Who sells them?


    Am i supposed to answer that? !! Try newegg.com :-|
  9. You have Shader model 2. That is Direct X 9

    The game wants Shader Model 3. That is DirectX 9c(Hardware support, sure you can install 9c, but the card will not use the features)

    What game is it? Some games(Bioshock comes to mind) that needed SM3 has user patches to make them work on SM2 hardware.
  10. Time for a new PC
  11. It's Lego Harry Potter: Years 5-7 :)
  12. eag270 said:
    It's Lego Harry Potter: Years 5-7 :)

    For that game you will most defiantly need SM3.
    Since we can't guess as to what the rest of your hardware is it is going to be hard to even recommend a video card for you. We need to know at least if your mainboard is AGP or PCI-E or god forbid PCI? What CPU make/model/speed?
  13. Here are the MINIMUM system requirements just to run the game.
    Your video card is simply too outdated. Depending on the PC you have, you may be able to purchase a newer video card. But if the rest of the machine is as dated as the video card, it may indeed be time to start looking for a complete newer PC as it would not be worth spending money for just the card.

    CPU: Dual core CPU @ 2GHz (Pentium D or better)
    RAM: 1GB RAM
    VGA: NVIDIA 6800, 7600, 7800, 8xxx or better, ATI 1950 or better
    DX: DirectX 9.0c
    OS: Windows XP, Windows Vista or Windows 7
    HDD: 8GB of free hard disk space
    Sound: 100% DirectX 9.0c compatible Audio Device
    ODD: DVD-ROM drive
    Keyboard and mouse
  14. bryonhowley said:
    For that game you will most defiantly need SM3.
    Since we can't guess as to what the rest of your hardware is it is going to be hard to even recommend a video card for you. We need to know at least if your mainboard is AGP or PCI-E or god forbid PCI? What CPU make/model/speed?


    Mainboard is AHI
    Chipset is ATI Xpress 200 (RS480)
    CPU is AMD Athlon 64 3200+
    Windows XP Home Edition
  15. jitpublisher said:
    Here are the MINIMUM system requirements just to run the game.
    Your video card is simply too outdated. Depending on the PC you have, you may be able to purchase a newer video card. But if the rest of the machine is as dated as the video card, it may indeed be time to start looking for a complete newer PC as it would not be worth spending money for just the card.

    CPU: Dual core CPU @ 2GHz (Pentium D or better)
    RAM: 1GB RAM
    VGA: NVIDIA 6800, 7600, 7800, 8xxx or better, ATI 1950 or better
    DX: DirectX 9.0c
    OS: Windows XP, Windows Vista or Windows 7
    HDD: 8GB of free hard disk space
    Sound: 100% DirectX 9.0c compatible Audio Device
    ODD: DVD-ROM drive
    Keyboard and mouse



    I attempted to download DirectX 9.0c and it was fully downloaded when it stopped and said it "Cannot save due to insufficient permissions".
    My VGA is ATI Radeon x300/x500/x1050
  16. I am going to guess with a Athlon64 3200+(A real beast of a CPU when it was released) that your system is just too old as others are saying.

    The game specs list a dual core as needed.

    Sorry to say, but to get an enjoyable experience, you will need quite a bit of upgrades. Since your cpu is older(socket 754 or 939), you have no more upgrade path with new parts(used, maybe).

    At this point, even an entry level system will be faster.

    I know this is not the news you want to hear, but that what it is.
  17. nukemaster said:
    I am going to guess with a Athlon64 3200+(A real beast of a CPU when it was released) that your system is just too old as others are saying.

    The game specs list a dual core as needed.

    Sorry to say, but to get an enjoyable experience, you will need quite a bit of upgrades. Since your cpu is older(socket 754 or 939), you have no more upgrade path with new parts(used, maybe).

    At this point, even an entry level system will be faster.

    I know this is not the news you want to hear, but that what it is.


    So, basically, I have to buy a new computer? :o
  18. eag270 said:
    So, basically, I have to buy a new computer? :o

    Yes you have to buy a new computer unless you settle for older games. You can't just "download" an upgrade no offense.
  19. Your CPU does not meet minimum game requirements either (your need a dual core processor) so unfortunately, your computer is just a little too aged for this particular game.
  20. Thanks guys :)
Ask a new question

Read More

Graphics Cards Games Graphics