Sign in with
Sign up | Sign in
Your question
Solved

USB ports not powering my keyboard?

Last response: in Components
Share
January 9, 2013 10:01:48 PM

I'll start off with me buying the keyboard, It's a noppoo choc mini. The keyboard worked fine for a week or so and after not using it for a weekend it decided to stop working. My computer will power the keyboard i'm using now (razer anansi) and my mouse, a razer naga no problem, they work without a hitch.

Please note that this keyboard works PERFECTLY while on another computer.

When i plug in my noppoo however one of three things will occur:

1. The "Caps Lock", "Num Lock", and "Scroll Lock" LED's will come on (they're the only 3 LED's on the keyboard) no other keys can be pressed and the aforementioned keys cannot be turned off.

2. Nothing will happen, no lights, nothing.

3. The keyboard will turn on (no LED's will be on which is normal)

I am trying to remember what i did and the only thing i can possibly think of is that i air dusted the back of my computer, with an air duster specifically designed for computers. But i'm not sure when I did that, whether it was before or after my keyboard stopped working, so take the above statement with a grain of salt.


Seriously if anyone can help me solve this it would be great.
Regards, Nick
January 10, 2013 1:47:58 AM

cmon guys i wrote this out nice if someone could help i would love you
m
0
l
January 10, 2013 2:10:02 AM

Try it in a couple of different USB ports, front and back.
If you have it in a USB3 port, try a USB2 port.

Also try wiggling the cable and the plug in the socket in case there is an intermittently broken connection.

Maybe you plugged in some additional USB devices and you are now exceeding the internal USB hub's ability to power the device. Try unplugging all other USB devices and see if it works. Also try it on a self powered external hub if you have one.
m
0
l
Related resources
January 10, 2013 4:07:15 PM

Tried on every USB port, none of them work with the keyboard but work with other things. The cable wiggling doesn't help, i tried unplugging everything and still it dosn't work.
m
0
l
January 10, 2013 7:59:03 PM

Do you have a hub available? Some LCD monitors have USB hubs in them.

If you try a self powered hub and keyboard still doesn't work (but keyboard does work in other machines) then you should also consider that it might be a software issue. e.g. device drivers.
m
0
l
January 11, 2013 2:00:39 PM

It's a noppoo choc mini, there are no drivers that go along with it. If you're talking about another driver please clarify.
m
0
l

Best solution

January 13, 2013 8:28:50 PM

All keyboard have drivers, it is just a question of if a suitable drivers are loaded automatically or not.
(Standard drivers are like, i8042prt.sys & kdbclass.sys)

But I also just read this post, which sounds similar to your problem.
http://geekhack.org/index.php?topic=23304.0
They are claiming that,
"The connection between the usb wire and PCBA board is loose . just get a new one .
this problem is common on the fisrt batch of mini 84, in China, Noppoo will offer you a new usb wire for free to replace the old one. They fix this problem in the later batch , the white pbt version does not have this problem ."



Share
January 13, 2013 9:42:13 PM

Best answer selected by nickvsyou.
m
0
l
January 13, 2013 9:42:36 PM

Passmark, you're awesome. Solved my problem, the keyboard is working now.
m
0
l
!