Sign in with
Sign up | Sign in
Your question
Solved

Low FPS in games?

Last response: in Systems
Share
August 27, 2012 12:20:36 AM

Link for parts is broken.

More about : low fps games

August 27, 2012 12:20:50 AM

Hey there. I recently had this computer built by a good friend of mine a couple weeks ago. It's the first computer I've spent a good amount of money on so I'm kind of paranoid. I get about 20 - 30 FPS in GW2 on the settings it Auto-Detects for me and about the same if not lower on Diablo 3 when it Auto-Detects. It Auto-Detects everything to High, so Idk if that it's going to high for my CPU or if my CPU should be able to run at that perfectly smooth.

http://i.imgur.com/pn5rH.jpg - Here is CPU-Z, HWMonitor, and Speedfan.

http://i.imgur.com/h21f4.jpg - Here is Cinebench 11.5. Don't know much about it, but it says 4 cores/8 threads?

http://i.imgur.com/AxFgZ.jpg - HWMonitor and Speedfan after playing games for about an hour. 20 - 30 frames GW2.

http://i.imgur.com/7qana.jpg - CYRI for some games.

All the parts:

http://secure.newegg.com/WishList/PublicWishDetail.aspx...


It may not be the best set up ever, but I still think it probably should run games better at the settings it Auto-Detects. Then again, I'm not good with computers so looking at this information I have no idea what could be wrong. If you see anything strange or there is anything else I could do that would help me, please let me know. Thanks!
August 27, 2012 12:26:47 AM

obsama1 said:
Link for parts is broken.


Should be fixed now.
Related resources
August 27, 2012 12:41:35 AM

I'd check out what's going on with that GPU. Zotac has a lot of bad reviews about them being shipped broken. But like obsama1 said, check to make sure your drivers are up to date first. Hope this helps.
August 27, 2012 12:43:01 AM

obsama1 said:
Shouldn't be getting such low FPS. First, update the GPU drivers. Here's the link for Windows 7 64-bit.

http://www.geforce.com/drivers/results/46279


For some reason it's taking a LOOOONG time to download and I'm pretty sure I already downloaded it anyways. GW2 suggested the beta driver when I first started playing.
August 27, 2012 12:45:45 AM

OK, just quickly check which driver version you currently have.
Here's how:

Q: How can I find out what driver version I have?

A: Right-click on your desktop and select NVIDIA Control Panel. From the NVIDIA Control Panel menu, select Help > System Information. The driver version is listed at the top of the Details window. For more advanced users, you can also get the driver version number from the Windows Device Manager. Right-click on your graphics device under display adapters and then select Properties. Select the Driver tab and read the Driver version. The last 5 digits are the NVIDIA driver version number.
August 27, 2012 12:45:59 AM

If it's not 304.79, then just continue with the download and install.
August 27, 2012 12:50:35 AM

Driver Version: 9.18.13.479

This was under Device Manager.
August 27, 2012 12:54:15 AM

Did you install the drivers from the DVD/CD? Just download the beta driver I've linked.
August 27, 2012 12:59:02 AM

obsama1 said:
Did you install the drivers from the DVD/CD? Just download the beta driver I've linked.


It was from the Nvidia site, but the beta driver is installed now.
August 27, 2012 1:00:13 AM

Restart, try the game, and report back.
August 27, 2012 1:11:52 AM

obsama1 said:
Restart, try the game, and report back.


About 20 - 30 in a big city and about 25 - 40 in the open world. It Auto-Detects my settings to the same as Best Performance.
August 27, 2012 1:16:48 AM

Did you install all the Windows updates?
August 27, 2012 1:20:49 AM

obsama1 said:
Did you install all the Windows updates?


All that it's given me, yes.
August 27, 2012 1:22:15 AM

Change the video settings in the game. Mess with them until you find a good FPS rate with the visuals you want.
August 27, 2012 1:23:33 AM

I know this is a dumb question but:

Is GW2 up to date?

Also, if all of this doesn't work, try updating your BIOS. But, if you don't know what you're doing, don't update.
August 27, 2012 1:23:39 AM

Also, there are 3 revisions of your mobo, so check in the BIOS what revision yours is before updating.
August 27, 2012 1:25:08 AM

obsama1 said:
I know this is a dumb question but:

Is GW2 up to date?

Also, if all of this doesn't work, try updating your BIOS. But, if you don't know what you're doing, don't update.


Well it just released, so it could still be having problems, but Diablo 3 has it's little fps flickers too. WoW runs great, but that doesn't take much, and so does SWTOR.
August 27, 2012 1:44:35 AM

I think it's a problem with the game, much like when Skyrim first came out. Checked Google News, it says the servers are being pounded, so that's probably why the low FPS.
August 27, 2012 2:10:47 AM

obsama1 said:
I think it's a problem with the game, much like when Skyrim first came out. Checked Google News, it says the servers are being pounded, so that's probably why the low FPS.


Ok, thanks for all the help. I did figure out my MOBO's revision is 1.1 though, so should I see about an update or just wait for the future? Also, is my computer doing ok while runnings games? It's not getting too hot, is it?
August 27, 2012 2:11:33 AM

ojas said:
You should be running driver version 301.42, it's the last WHQL driver for the 500-series cards.
http://www.nvidia.in/object/win7-winvista-64bit-301.42-...


ArenaNet suggests the beta drivers for GW2 and says 301.42 will make the game's performance worse. Some people are talking about 305.67 working well. I don't know though.
August 27, 2012 2:33:19 AM

F8. Don't risk it.
August 27, 2012 3:00:00 AM

obsama1 said:
F8. Don't risk it.


'Tis done. Guess testing time again.
August 27, 2012 5:18:52 AM

obsama1 said:
Guy on DSLReports forum says 305.67 drivers fix GW2 FPS issue. Scroll down and DL it here:

http://www.nvidia.com/content/devzone/opengl-driver-4.3...


Yup, using it now. 50 - 60 frames, but running on Med settings instead of High. Maybe it'll get better with more updates. Diablo 3 is still glitchy with lots of monsters, but is good. My friend keeps insisting I should be able to play max settings on both the games with no problems, but I don't know what else to do.

Best solution

August 27, 2012 5:40:44 AM
Share

You should. The 570 should shred those games but apparently like you said, the games are glitchy. Oh also, install the bulldozEr hotfixes to improve performance.
http://support.microsoft.com/kb/2646060
http://support.microsoft.com/kb/2645594
August 28, 2012 1:24:07 AM

Report back with your results, if that's no trouble.
August 28, 2012 4:20:01 AM

obsama1 said:
Report back with your results, if that's no trouble.



I downloaded them and the new 306.02 beta driver that's supposed to be better for GW2, but idk, it still seems weird. I'll keep testing it.

Edit: Nothing really noticeable. 50 - 60 on Med settings and Vsync on. I'm having a friend of mine who has built a lot of computers look at it soon to see what he thinks.
August 28, 2012 7:21:55 AM

you wont get more than 60 FPS with Vsync on

Its matching the video card output to the actual refresh rate of your monitor . Turn up detail settings till you start to see a slow down
August 28, 2012 12:16:29 PM

Outlander_04 said:
you wont get more than 60 FPS with Vsync on

Its matching the video card output to the actual refresh rate of your monitor . Turn up detail settings till you start to see a slow down


I know, but without it on, my FPS will jump from 40 to 80 lol. Idk, saw a lot of people using it so thought it would be good.
August 28, 2012 2:42:38 PM

If you check Tom's assessment of GW2, it seems that the game isn't optimized for Bulldozer.
August 28, 2012 4:10:15 PM

use adaptive vsync.
August 29, 2012 4:02:51 AM

Best answer selected by valrath21.
August 29, 2012 4:04:33 AM

obsama1 said:
If you check Tom's assessment of GW2, it seems that the game isn't optimized for Bulldozer.


Diablo 3's problem was Vertical Tearing and VSync fixed that. WoW runs at 100-150 fps.

It must just be GW2. I'll wait for more updates and such. Thanks for all your help guys. You especially obsama1.
August 29, 2012 4:09:26 AM

NP. Hope it gets fixed!
August 29, 2012 7:09:58 AM

Your problem is that your video card does not switch to power mode from power saving mode when application is launced. Check GPUZ, it should show your PCI-E is working on x1 when PC is without laod, for example: pci-e 3.0 x16 @ x1 1.1

Now if you launch a game or use "?" in GPUZ, your graphic acceleration should switch to x16 mode, in our sample: pci-e 3.0 x16 @ x16 1.1 If it doesant, you face a huge performance issue.

It is related to PC BIOS. In my case, the solution was easy - I just changed CPU frequenzy +1 in BIOS and the problem was solved. FPS in GW2 changed from ~15 to 80 (7850). If this is not the case for you, please check here.

August 30, 2012 10:41:07 PM

Killhoven said:
Your problem is that your video card does not switch to power mode from power saving mode when application is launced. Check GPUZ, it should show your PCI-E is working on x1 when PC is without laod, for example: pci-e 3.0 x16 @ x1 1.1

Now if you launch a game or use "?" in GPUZ, your graphic acceleration should switch to x16 mode, in our sample: pci-e 3.0 x16 @ x16 1.1 If it doesant, you face a huge performance issue.

It is related to PC BIOS. In my case, the solution was easy - I just changed CPU frequenzy +1 in BIOS and the problem was solved. FPS in GW2 changed from ~15 to 80 (7850). If this is not the case for you, please check here.


I set it to manual and changed the DEC or whatever to 201, but I'm getting pci-e 2.0 x16 @ x4 2.0 when running that test with GPUZ.
August 31, 2012 12:20:14 AM

It won't let me edit my last post, so I had to make a new one.

Not sure about this. I probably should have asked first, but I moved the Graphics Card to a different slot that says x16 and now it's running at pci-e 2.0 x16 @ x16 2.0. Still about the same frames though sadly. Is there anything else I need to do? I also tried setting the DEC or whatever to 201 Manual instead of 200 Auto.
!