Sign in with
Sign up | Sign in
Your question

USB 3.0 Not working :(

Last response: in Components
Share
January 10, 2013 2:53:30 PM

Hi,
I recently decided to upgrade my PC so it would have USB 3.0 capability, so I got a USB 3.0 PCI-e card and also a card reader with a USB 3.0 port on it for the front of the PC. All went well during installation and then I tried a USB 3.0 external hdd on it.

Nothing.

Well I say nothing, the ports are giving the hdd power as it spins up as usual and the light on the front flashes, but nothing is picked up by Windows, also when I tried installing the included drivers, the installer reported that no compatible hardware was found. I also tried a UBS 2.0 flash drive and also nothing happened. Neither the front or back ports work apart from giving the devices power.

My specs (should you for some reason need them)

Windows 7 Home Premium
320gb SATA hdd
4gb RAM
3.4ghz AMD Phenom II x2 565 Black Edition
Radeon HD 5670 graphics

Things I have already tried:
Making sure the PCI-e card is in correctly
Removing all unnecessary USB drivers
Deleting the infocache.1 file and re-generating it


Any ideas?

More about : usb working

January 10, 2013 3:12:51 PM

Do you see the card in device management? If not, it's either still not seated right or it's dead. Is it a pci-e x1 card? Then you can try to unscrew the shield and stick it in the slot without it just for testing.
January 10, 2013 3:35:56 PM

Ok so the card does work.

I continued trying to make it fit in the slot securely and after a reboot it worked and I could install the drivers. After that it worked, until I removed the USB cable in the back of the PC (the ports provided by the card) when I did this the whole card moved and then it now does not work again.

The problem is clearly that it does not fit securely in the PCI-e slot, but when the card is in the PCI-e slot the back panel is not all the way into the frame, making the back panel too long so I can not secure it with a screw.
January 11, 2013 10:28:34 AM

The back panel should be screwed to the card. Loosen the screws a bit an try to fit it in the slot then.
!