Sign in with
Sign up | Sign in
Your question

Amd Driver stopped responding

Last response: in Graphics & Displays
Share
July 8, 2012 5:32:27 PM

I recently setup my new computer and Radeon gpu but I have two issues. One is that every time I open a graphical application (any game, even 2d/flash) my screen goes black, distorted or checkered and windows says that the amd driver has stopped responding and has successfully recovered. I looked up solutions and reinstalled the latest drivers in safe mode, checked my memory with memtest and installed any windows or bios updates as suggested by people and nothing has worked to fix this so far. How can I fix this? Thanks in advance
a c 99 U Graphics card
July 8, 2012 7:52:32 PM

What is the card?

And how many video related programs do you open at the same time?
m
0
l
July 8, 2012 8:40:45 PM

Oh dammit i can't believe I forgot to mention the card. It's a Sapphire Radeon HD6870 and I only open one at a time.
m
0
l
Related resources
a c 99 U Graphics card
July 8, 2012 9:08:26 PM

What version driver are you using? And which drivers have you used.
m
0
l
July 8, 2012 9:22:19 PM

im using catalyst 12.6 and i've used 11.5 which I have totally removed with driver sweeper in safe mode before I installed the update.
m
0
l
a b U Graphics card
July 8, 2012 9:34:47 PM

update flash player.. and or microsoft silver light . if your having issues with web videos also its still a good idea to run the uninstall option before you install 12.6 even if you used drive sweeper .. your registry might have errors in it..
m
0
l
a b U Graphics card
July 8, 2012 9:36:20 PM

also i noticed there are some bugs with ssd drives waking from sleep and then trying to play a game or video and it wont display properly ..
m
0
l
a b U Graphics card
July 8, 2012 9:58:06 PM

its either (usually):

drivers
power supply
faulty card
m
0
l
July 9, 2012 2:04:40 PM

Ok, I'm upgrading my psu after the holiday cause right now I have a cheap one so that's gonna be fine and I had flash player and silverlight (latest) already installed. I'm gonna try re-installing the drivers one more time but uninstalling first as suggested or using 12.4 or 12.3. And if that doesn't work and my new psu or reinstalling windows 7 over again doesn't help I'm switching to Nvidia. Thanks everyone.
m
0
l
!