Sign in with
Sign up | Sign in
Your question

Broken boot sector?

Last response: in Storage
Share
Anonymous
a b G Storage
September 10, 2001 5:05:59 AM

I seem to have stuffed my boot sector using partition magic. At least that's my guess.

I was running dual-boot with win2k and linux, I decided to make a new partition so I could have a look at XP but I'm new to partition magic and that's where I think I stuffed up. I moved my linux partitions up the drive and tried to squeeze in an NTFS partition between linux and windows, which all seemed to go well but after rebooting the LI-LO boot loader didn't load, instead all I got was:

Verifying DMI Pool Data.....
LI_ (the _ is a flashing cursor)

I've tried everything on this drive since then to get it to boot but it won't. As for the data and existing partitions, I had access to all the data, I have since removed and backed up neccessary stuff and completely reformatted and repartitioned the drive.

The drive will let me install Windows 2000 but it will not boot.

I also tried loading a ghost image to the drive, the load was successfull however the drive still won't boot.

I'm no expert but my guess is that when I installed linux, it's boot-loader program location was written to the boot record/boot sector thingy and then when I moved the linux partition the bootloader was no longer where it was expected to be.

My question... how do I fix this if indeed it is the boot sector I've broken?

If it's not the boot sector, what have I done?

Thank you for your time, as always, any help received will be greatly appreciated.

Jeffro.

P.S: Drive is a Quantum Fireball LM20.5

System: Abit KT-7, Tbird 800, 384 PC133, Gf2 MX, SBLive!

More about : broken boot sector

September 10, 2001 6:11:51 AM

check out the Maxtor web site for info on quantum utilities. u need the disk manager or disk go.. whatever quantum uses. it creates a bootable floppy when you decompress the file. what you may need to do is a zero fill and set the drive as your bootable drive, the utility usually writes over everything.. let me know if this works.
September 10, 2001 10:00:56 AM

I had this LI thing some time ago, VERY annoying, this was during an nt4 (i think-could have been 2k) install, it started installing then when it came to the reboot, thats what I got, in my case I fdisked/formatted the dam drive at least 6 times, same every time in the end I threw the dam thing in the bin! (was only a 3 gig thing), put in a new one and worked ok, VERY STRANGE, I'd like to know how you fix it (I hope you DO fix it)
This drive also had linux on it, dual booting redhat 6.2 and nt4, had probs which is why I reformatted and started installing again.


Next time you wave - use all your fingers
Related resources
Anonymous
a b G Storage
September 10, 2001 11:58:05 AM

re the lilo thing:

From the bootdisk-howto:

LI means "The first stage boot loader was able to load the second stage boot loader, but has failed to execute it. This can either be caused by a geometry mismatch or by moving /boot/boot.b without running the map installer."

...so if you moved your linux partition, and you only have the one - no separate boot partition -, then you probably moved your boot.b, and broke lilo.

as for fixing it? well... you need to boot a rescue disk of sorts, maybe the cd that came with your distro, and re-run lilo to update the boot sector with the new location.

also, i think the boot partition needs be located under the 2-gig mark.
September 10, 2001 3:31:33 PM

I just had this problem this weekend as well.. but maybe mine is worse? It hangs at "Verifying DMI Pool Data..." and there is nothing else after that.

I tried using a boot disk, but then after it runs, it says that the C: is not even there! So now what do I do... ?

To compound the problem, my A: wasn't working earlier last week out of the blue. Then after plugging in the cables and power to it a million times, it magically worked. Now it doesn't work again while I've been playing with this stupid HD ... hopefully I can get the floppy back online, otherwise I'm without a bootdisk as well :frown:

But umm.. say I get the A: to work, what good is it if the C: isn't recognized? At startup when it detects IDE drives, the HD is found with model number and everything. Bios says it is there as well.

I was reading about DMI pool data problems and they said to disable internal and external cache. Then when it reboots DMI pool data says "update success" afterwards, you're supposed to re-enable the cache. then it does 'update success' for the pool data again. But then it just hangs as usual when it's *supposed* to go on good from there. Crap.

Sorry for the long post, hope someone can help, or maybe that DMI resetting can help the original guy :smile: I don't have the time for this kind of problem! Is there a cheap but reliable computer shop in Boston to fix it for me? heh

:tongue: <font color=red>"Never pick a fight with an ugly person .. they have nothing to lose" </font color=red> :tongue:
Anonymous
a b G Storage
September 11, 2001 3:15:50 AM

I suspect you're dealing with a different kettle of fish here... I wonder if there aren't other things going on as well, if you keep losing your A: drive.

Try clearing your CMOS - should be a mobo jumper for that - and maybe download a disk utility from your HD manufacturer to reinstall the boot sector. (if that's where the problem is...)

Have you stripped the box down to try to eliminate other issues? It just doesn't sound like a boot sector thing to me...

...cheap _AND_ reliable...? ;-) good luck!
September 11, 2001 9:13:22 PM

d/load the disk utilities from the supporting website, you can't simply FDISK the problem away with linux for some reason, i had linux on a dual(triple) boot with 98 and 2k and nothing worked right until i did a zero fill. then you can use the utility disk partitioner/formatter and if needed the format command. its the long way and im sure theres a shorter one, but think of it this way, a few hours or a drive in the garbage. you can even run some diagnostics on it
Anonymous
a b G Storage
September 14, 2001 6:22:31 AM

Thanks to all who replied, problem is now solved.

FDISK /MBR

That was it. Partition magic had moved the LILO boot loader, and not told the boot sector where it had moved it to, just like I had figured, but I never figured the fix would be so simple and virtually staring me in the face the whole time (I'd been fdisking for over 3 hours =p).

Anyway, I hope this can help anyone else with problems of a similar nature.
!